summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-12-21 19:00:23 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-12-21 19:00:48 +0300
commit1bc4f8ad3173053fd6884e077e6c6d403ded09a3 (patch)
treed0a703a4ecc918d23e8600a43adfa88bd94b628f /app-emulation
parentsys-kernel/gentoo-sources: Linux patch 4.4.169 (diff)
downloadgentoo-1bc4f8ad3173053fd6884e077e6c6d403ded09a3.tar.gz
gentoo-1bc4f8ad3173053fd6884e077e6c6d403ded09a3.tar.bz2
gentoo-1bc4f8ad3173053fd6884e077e6c6d403ded09a3.zip
app-emulation/docker-compose: Version bump (v1.23.2)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.23.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index c98f39b21eac..182767853e77 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -2,3 +2,4 @@ DIST docker-compose-1.19.0.tar.gz 238307 BLAKE2B 2a7bbcf50c2cc591eba1d59db30cb03
DIST docker-compose-1.21.2.tar.gz 294070 BLAKE2B c27ce8708f20385ee3f072c4aa832a42dc975d08d71d9e61ce3a822055d606db7e1e7b6e182523e64115922416d5c1baeca14897a241e84873a97aa755bce539 SHA512 6392582d8c6c321458b1163336f1c902548cc250f9ab5b765d144287b006ef6dacdc47199fafbb6efe426e382325b94986aa159df08dec4974a71968862a8435
DIST docker-compose-1.22.0.tar.gz 296747 BLAKE2B 9dfd25fb186436801d9c12900c4103c1c0d83bee3b424b3f2373247aeeb8261fed04cf9be9cee230a48e1c19523b48d5618a18f322c236bac1d769036f9ac979 SHA512 eccef2165221fcfdac089ffd3bd0795d08d8c6f7158709dbc2fc83a6d6e9466af4b73c0c7d24a751c6b546b4219e10dfc96cd41e13e7ebc676da603c97b7620e
DIST docker-compose-1.23.1.tar.gz 302224 BLAKE2B 510a6236194297dd68b3b1a00239142d0f5dd1cacb79a82604a22e7f57581f778ad6027d0108ff896e9f4354c5eb0e1fb2ceea4285bee6a47e5cb8e32a3e5a75 SHA512 d294663e575657c361602693d66aca1ae3c0f5d4b25a74f4ab575be34054dc3168cb77d59fedf981f6bc98e253e87791187440f10c6957254c4f2e29ef7063d0
+DIST docker-compose-1.23.2.tar.gz 302950 BLAKE2B b96db2e718bd6b05f6a35829749570320209def17b7536e402b9991b56e05a2d8da97fbd8d79d8125d9df6ff361a181fbfd71346a33a68704db0327a92757f66 SHA512 baa233c84ac770798ba3d8d256687630b331d774a8d60f3c0d5046aa0a74c8c3b8b0b8bc4431f3bc7d5b7a54f0646f5e2fd14d5af31db37cb546e86c96c8c1db
diff --git a/app-emulation/docker-compose/docker-compose-1.23.2.ebuild b/app-emulation/docker-compose/docker-compose-1.23.2.ebuild
new file mode 100644
index 000000000000..67051b8efed6
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.23.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,6}} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2
+ >=dev-python/docker-py-3.6.0[${PYTHON_USEDEP}]
+ <dev-python/docker-py-4.0
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ <dev-python/requests-2.21
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.10
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+
+S="${WORKDIR}/compose-${PV}"
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}