summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-08-20 10:32:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-08-20 10:32:28 -0500
commit273a0cddc01668369b85b68375ee021bb9179ff8 (patch)
tree219da8652f4c591a98b7e7fdee8ce21adaf5910e /app-emulation
parentapp-admin/ansible: 2.9.9 cleanup (diff)
downloadgentoo-273a0cddc01668369b85b68375ee021bb9179ff8.tar.gz
gentoo-273a0cddc01668369b85b68375ee021bb9179ff8.tar.bz2
gentoo-273a0cddc01668369b85b68375ee021bb9179ff8.zip
app-emulation/diskimage-builder: 3.2.0 bump
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index ce27588ce8dc..d95ddc119f7f 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.1.0.tar.gz 434813 BLAKE2B 7a9fa54353f9b7edc2f1f1dab965b8241cb8b046ef56f12ed3562c04a8c6e236a7be41fbe75c385b48c4f2b8b30e961d8b86499e79999c391dde9c2f294f1193 SHA512 0b8a0b6cee9c7fcee08d8e5d706add2e54dfe1b7726b169f357022a48a37e351b159a7426771a001b703ca4360905f318ff91d0e72cb2d92e3486607186d03c4
+DIST diskimage-builder-3.2.0.tar.gz 448407 BLAKE2B 505aec0375b1adab03362025e5f391b771e128bf3fd21fe312bdf0a60be7e5ef5768f61778425f24471d6943788ade98929949623142923548e37a8fef65dd53 SHA512 675f1d733c82a15862db2db1c7362fe50058b89b834bffa46ef936af450e41796c06f32f2677ac787100fc2b285f6f7befdd7344a4463841b0ca581499018849
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.2.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.2.0.ebuild
new file mode 100644
index 000000000000..720474e33c48
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"