summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-11-18 14:38:49 -0600
committerMatthias Maier <tamiko@gentoo.org>2016-11-18 14:38:49 -0600
commit2a846f0e0ec1edfb52c34d1ff3e2cd1c9eac44aa (patch)
tree4397a061767e11b85f43a0eb73b6f845d2fd265f /app-emulation
parentapp-emulation/libvirt-glib: stabilize 0.2.3-r1 for amd64 and x86 (diff)
downloadgentoo-2a846f0e0ec1edfb52c34d1ff3e2cd1c9eac44aa.tar.gz
gentoo-2a846f0e0ec1edfb52c34d1ff3e2cd1c9eac44aa.tar.bz2
gentoo-2a846f0e0ec1edfb52c34d1ff3e2cd1c9eac44aa.zip
app-emulation/libvirt-glib: version bump to 1.0.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/Manifest1
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-1.0.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
index 4a1c8126a24f..8f7b0f143b7e 100644
--- a/app-emulation/libvirt-glib/Manifest
+++ b/app-emulation/libvirt-glib/Manifest
@@ -1 +1,2 @@
DIST libvirt-glib-0.2.3.tar.gz 876258 SHA256 c3b11aa34584b3416148b36bb005505e461830c73c9fd2f40143cca3309250dd SHA512 007e642724658e7f2d4ad10094e70a93186196467140662d5e71644ae8efac25a7f60dcf51b55b60d056d3079ecf0798428e077cb6110292ce5f2a474db9e369 WHIRLPOOL 594ab70f4647e053d9540e857aeba7853491200d825eed713a1025afe5eabbe2f3c698d30b00e0da1735f2fc8465212eae2a965fb93a68099df5d11ce494a0d2
+DIST libvirt-glib-1.0.0.tar.gz 860450 SHA256 ca9158d01cc4d9e0218f94f8c9ee04ae367d8c3b4396daaebca2c4b89a2e8a47 SHA512 72f53a90d3e40aa93d4afe5b29f631afe859532fbdb4e27086da3bd4cdaf0fb25fc808a82a1994b7c2648a1e864876ce95de28acb3b4876dac47b0f4d1c97ba5 WHIRLPOOL 66abe839eca288690e0637f72a3f3ef550b3dd0bb2a90102cb9fb2fa2889addbce2d30eed8a776ffbf9021b48e5822068d600b9544ce4ff558df3f00638a9e98
diff --git a/app-emulation/libvirt-glib/libvirt-glib-1.0.0.ebuild b/app-emulation/libvirt-glib/libvirt-glib-1.0.0.ebuild
new file mode 100644
index 000000000000..662429c62bed
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-1.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls python +vala"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ vala? ( introspection )
+"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-1.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable vala) \
+ $(use_with python)
+}