summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2020-07-28 17:32:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-16 11:00:58 +0300
commit322843625dc2aae3e5955c609a4238ec478bf54a (patch)
tree1d004da8faea5471d861a1cf7291a7ccfa01bde4 /app-emulation
parentapp-emulation/fuse: avoid /usr/lib in the link command line (diff)
downloadgentoo-322843625dc2aae3e5955c609a4238ec478bf54a.tar.gz
gentoo-322843625dc2aae3e5955c609a4238ec478bf54a.tar.bz2
gentoo-322843625dc2aae3e5955c609a4238ec478bf54a.zip
app-emulation/fuse-utils: avoid /usr/lib in the link command line
Closes: https://bugs.gentoo.org/734210 Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16885 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fuse-utils/files/remove-local-prefix.patch22
-rw-r--r--app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild13
2 files changed, 34 insertions, 1 deletions
diff --git a/app-emulation/fuse-utils/files/remove-local-prefix.patch b/app-emulation/fuse-utils/files/remove-local-prefix.patch
new file mode 100644
index 000000000000..41daba71cdd9
--- /dev/null
+++ b/app-emulation/fuse-utils/files/remove-local-prefix.patch
@@ -0,0 +1,22 @@
+diff -Naur fuse-utils-1.4.3/configure.ac fuse-utils-1.4.3-patched/configure.ac
+--- fuse-utils-1.4.3/configure.ac 2018-07-01 02:09:55.000000000 +0200
++++ fuse-utils-1.4.3-patched/configure.ac 2020-07-28 17:02:05.287721692 +0200
+@@ -92,18 +92,6 @@
+ )
+ fi
+
+-dnl Allow the user to say that various libraries are in one place
+-AC_ARG_WITH(local-prefix,
+-[ --with-local-prefix=PFX local libraries installed in PFX (optional)],
+-CPPFLAGS="$CPPFLAGS -I$withval/include";
+-CXXFLAGS="$CXXFLAGS -I$withval/include";
+-LDFLAGS="$LDFLAGS -L$withval/lib",
+-if test "$prefix" != "NONE"; then
+- CPPFLAGS="$CPPFLAGS -I$prefix/include";
+- CXXFLAGS="$CXXFLAGS -I$prefix/include";
+- LDFLAGS="$LDFLAGS -L$prefix/lib"
+-fi)
+-
+ dnl Check if libjpeg is available and supports jpeg_write_scanlines
+ AC_MSG_CHECKING(whether to use libjpeg)
+ AC_ARG_WITH(libjpeg,
diff --git a/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild b/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
index fb8728c0836b..8e44998a4a6a 100644
--- a/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
+++ b/app-emulation/fuse-utils/fuse-utils-1.4.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Utils for the Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -20,6 +22,15 @@ RDEPEND=">=app-emulation/libspectrum-1.4.4[gcrypt?,zlib?]
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
$(use_with audiofile)