summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-06 23:31:19 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-17 00:22:34 +0100
commit3baf5a5158b264648f59c99c172a8bb3c9b92fe7 (patch)
treec95672ca6b86979f674bef544660c1f6601bd07e /app-emulation
parentapp-pda/barry: Port to EAPI 7 (diff)
downloadgentoo-3baf5a5158b264648f59c99c172a8bb3c9b92fe7.tar.gz
gentoo-3baf5a5158b264648f59c99c172a8bb3c9b92fe7.tar.bz2
gentoo-3baf5a5158b264648f59c99c172a8bb3c9b92fe7.zip
app-emulation/wine-vanilla: revert winegcc '=' parameter handling
LDFLAGS=-Wl,--defsym=__gentoo_check_ldflags__=0 causes wine-vanilla-6.12 build failures in form of: ``` tools/winegcc/winegcc -o dlls/acledit/acledit.dll.so ... \ -Wl,--defsym=__gentoo_check_ldflags__=0 ld:--defsym:0: syntax error collect2: error: ld returned 1 exit status winegcc: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc failed ``` The change is a revert of upstream commit fcda0afd ("winegcc: Support -Wl,foo=... style linker options.") Bug: https://bugs.winehq.org/show_bug.cgi?id=51413 Closes: https://bugs.gentoo.org/800809 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21618 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/files/wine-vanilla-6.12-winegcc-equals-args.patch13
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-6.12.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/files/wine-vanilla-6.12-winegcc-equals-args.patch b/app-emulation/wine-vanilla/files/wine-vanilla-6.12-winegcc-equals-args.patch
new file mode 100644
index 000000000000..562b63af063a
--- /dev/null
+++ b/app-emulation/wine-vanilla/files/wine-vanilla-6.12-winegcc-equals-args.patch
@@ -0,0 +1,13 @@
+https://bugs.winehq.org/show_bug.cgi?id=51413
+https://bugs.gentoo.org/800809
+--- a/tools/winegcc/winegcc.c
++++ b/tools/winegcc/winegcc.c
+@@ -1982,7 +1982,7 @@ int main(int argc, char **argv)
+ if (strncmp("-Wl,", opts.args->base[i], 4) == 0)
+ {
+ unsigned int j;
+- strarray* Wl = strarray_fromstring(opts.args->base[i] + 4, ",=");
++ strarray* Wl = strarray_fromstring(opts.args->base[i] + 4, ",");
+ for (j = 0; j < Wl->size; j++)
+ {
+ if (!strcmp(Wl->base[j], "--image-base") && j < Wl->size - 1)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-6.12.ebuild b/app-emulation/wine-vanilla/wine-vanilla-6.12.ebuild
index b16b5176cce9..e725ccf27b97 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-6.12.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-6.12.ebuild
@@ -144,6 +144,7 @@ PATCHES=(
"${PATCHDIR}/patches/${MY_PN}-4.7-multilib-portage.patch" #395615
"${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch" #310611
"${PATCHDIR}/patches/${MY_PN}-5.9-Revert-makedep-Install-also-generated-typelib-for-in.patch"
+ "${FILESDIR}/wine-vanilla-6.12-winegcc-equals-args.patch" #800809
)
PATCHES_BIN=()