summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-09 09:58:24 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-09 09:59:00 -0600
commit3fc759540b149b08d75e79396fd726cfced61ec9 (patch)
tree9b758b846ec2e5a5225665272853b5b2c2d34c86 /app-emulation
parentprofiles: Remove remaining linguas_* flags from use.desc (round 8). (diff)
downloadgentoo-3fc759540b149b08d75e79396fd726cfced61ec9.tar.gz
gentoo-3fc759540b149b08d75e79396fd726cfced61ec9.tar.bz2
gentoo-3fc759540b149b08d75e79396fd726cfced61ec9.zip
app-emulation/diskimage-builder: 2.10.0 bup
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.10.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 6c4a5ef56cf9..4b615fb47219 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-1.28.0.tar.gz 267409 BLAKE2B eec9e9bfba8ddbd31ec1af8fac401c64019c72c19982e7d74eb20f1056571873f5ed8198809b7ebd2ef87deb757a9a81b5a1ec23c83876abed659c1196df2cb0 SHA512 ae13e29563f90a4aaa4f2bee889bca4fd662da41fcffb957ca8a4380907e5d89fbc25ecb93aeda2cb5597776b51417388e8a5e39741250d68a8f7f67239ebc7f
+DIST diskimage-builder-2.10.0.tar.gz 338388 BLAKE2B c30f81f4cf2b0668d96dce49cab3aa79c484b7ee8a7c214bbc6f6f8e405d86e7240309bc266b4ac1cba14f19c82b2d67bd123d3e3e8af073ad8d4831301ae879 SHA512 37c3a6894ed30c69a6abe87524c08aa814158a01b1a5f17bf39ca9e905dd93eaab5a3f821ddddef73eafa5cf33b6cf0b8e30c6067b005c92c6029cdd7af5e8eb
DIST diskimage-builder-2.9.0.tar.gz 319035 BLAKE2B 846b2f35533efb66c22adb461b849352f17a8555998cf689756c513093d244c714a8e7b8ad7da4fada2b5da9ef3c2ac42f3247568b207e342a71d2ba677abda3 SHA512 ebaeb1d5396977d8391f7c718ff13e7b0d37aca58ff14719e2b5f17adc376e85f15f516f63c245c2374e363d4037bc358192aa87ce0515d0a69cb00ac5b616af
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.10.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.10.0.ebuild
new file mode 100644
index 000000000000..b7ce708c6881
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"