summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Balaev <mail@void.so>2022-10-17 11:15:58 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-11-02 16:24:25 +0200
commit429dd6b68a23f03becbdbea6b4cec36897d9483f (patch)
treeee1023b1f46be8c79944199b561d299677916193 /app-emulation
parentapp-emulation/firecracker-bin: add 1.1.2 (diff)
downloadgentoo-429dd6b68a23f03becbdbea6b4cec36897d9483f.tar.gz
gentoo-429dd6b68a23f03becbdbea6b4cec36897d9483f.tar.bz2
gentoo-429dd6b68a23f03becbdbea6b4cec36897d9483f.zip
app-emulation/nemu: add 3.1.0
Closes: https://bugs.gentoo.org/877395 Signed-off-by: Pavel Balaev <mail@void.so> Closes: https://github.com/gentoo/gentoo/pull/27819 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/nemu-3.1.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index b2e5dda24a18..1f7cb8e2f9a8 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1,2 +1,3 @@
DIST nemu-2.5.0.tar.gz 108742 BLAKE2B e68cbf50d56983873656d8e3428cb3ffaa09cafc9cbc8e545d72bf9dfb61e64a06bdc41c3f50011c4c488017efe33afe9fa1d634aae6e9151c45a7d3971c60db SHA512 081199413c41e545d23704091760c4a10b8dcdb21d9d0e6add1e549fa33bdd988490034767e08dee681eee6d06899104b8282cafc4578e06a0eabc505325bbdc
DIST nemu-3.0.0.tar.gz 151223 BLAKE2B a71875eb727eed13bc252cee072e1c5b25bf7ea106f51ddddfb8e8bfacf21e030b1c4045de2353d40121b78756b131de1a376891197f6d553430b4b30f53bf3e SHA512 59dae5364659dda5d7c05ba6378b6e20c5d2c5b619cb919c49036918a887574b75f5d568cbfa8f21ecf790778c9de55266f5c5e3e90cc991f613a6408b10a1df
+DIST nemu-3.1.0.tar.gz 164222 BLAKE2B 32600bcdcf2a4f963612a13d89375df2cb4a49a376aec694ada01a86f6c27d6c4198250834cc924bb20e7b60b11ff8643e3bbd30aa883b437cf7828ab00509f2 SHA512 b764e94133e4ab4f052fca77d3dbc64dbbd6a52349828e8ccfe9892f1a9bb290b6578cd8afec7bac84ac339daf9ae11520fce28e842bfa649178fe471014fad1
diff --git a/app-emulation/nemu/nemu-3.1.0.ebuild b/app-emulation/nemu/nemu-3.1.0.ebuild
new file mode 100644
index 000000000000..7bbe6f76ca86
--- /dev/null
+++ b/app-emulation/nemu/nemu-3.1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-info
+
+MY_PV="${PV/_rc/-RC}"
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://github.com/nemuTUI/nemu"
+SRC_URI="https://github.com/nemuTUI/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus network-map +ovf remote-api"
+
+RDEPEND="
+ >=app-emulation/qemu-6.0.0-r3[vnc,virtfs,spice]
+ dev-db/sqlite:3=
+ dev-libs/json-c
+ sys-libs/ncurses:=[unicode(+)]
+ virtual/libusb:1
+ virtual/libudev:=
+ dbus? ( sys-apps/dbus )
+ network-map? ( media-gfx/graphviz[svg] )
+ ovf? (
+ dev-libs/libxml2:2
+ app-arch/libarchive:=
+ )
+ remote-api? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+S="${WORKDIR}/${PN}-${MY_PV}/"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ # -DNM_WITH_QEMU: Do not embbed qemu.
+ local mycmakeargs=(
+ -DNM_WITH_DBUS=$(usex dbus)
+ -DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_REMOTE=$(usex remote-api)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ -DNM_WITH_QEMU=off
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ docompress -x /usr/share/man/man1/nemu.1.gz
+}
+
+pkg_postinst() {
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /etc/udev/rules.d"
+ elog "Afterwards reboot or reload udev with"
+ elog "udevadm control --reload-rules && udevadm trigger"
+}