summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-09 20:26:39 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-09 20:26:39 +0100
commit451c4c5f763fa6540a593443ea04893f89d5af7b (patch)
tree5a8241e5eda1037c85cb3d110c041dbab473317d /app-emulation
parentdev-db/etcd: Version bump to 3.3.0_rc1 (diff)
downloadgentoo-451c4c5f763fa6540a593443ea04893f89d5af7b.tar.gz
gentoo-451c4c5f763fa6540a593443ea04893f89d5af7b.tar.bz2
gentoo-451c4c5f763fa6540a593443ea04893f89d5af7b.zip
app-emulation/kompose: Version bump to 1.7.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-1.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index 12f9dec9d768..b2ee35d8b769 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1,2 +1,3 @@
DIST kompose-1.5.0.tar.gz 5184512 BLAKE2B e9b1f7d778e0128add41218c5cef8dc4e0272e85d1345948b73c3529ff6d7e17b05e8a821812e3a5f12f076d5c6c0411fa50be86ebaac54a300b263f705d10a1 SHA512 2b366ed84b5368ab8c8921a989462931edf8f4fe751e3f0ee18f1d6fd6f5bce1534e962e92d7c0d3474ed1c87f8c40b8e2e4eb1d63892ac84a41be79e527a6a1
DIST kompose-1.6.0.tar.gz 5227025 BLAKE2B e24e5d142db7a1e55c8e2c05db2a7717a6bc178c3ed73ec2732fb10ae39c90dd2da41ce604fc590e8888ef1b92d5ba68821f66f54e2285d90c2bc9e3af3f1da0 SHA512 57e8b3530ad260d0ed6a679119c559f616c45d407db8929797dbf321e32917bc236ac41e1042f65aa8460026d54cb03180e8b8264dadb6fe05ec6d21293140a3
+DIST kompose-1.7.0.tar.gz 5230263 BLAKE2B c2e50ceadaa3f88b5d6a9c6fbca93a0a45a16fb4d208a9194578174d9b67697f70d52f8f7a517609b56acf0cb646a9ca4e9137e1a830646e1084c10aabfd1cc0 SHA512 bcda4d891cdc8a0e331aad3baca9e88be32d302ed1ab89a561874881ec9e1dd04f7158f9315ee59a49d4906cc9d08821a417ff04a8ebe9871edece842b2e85b9
diff --git a/app-emulation/kompose/kompose-1.7.0.ebuild b/app-emulation/kompose/kompose-1.7.0.ebuild
new file mode 100644
index 000000000000..db671c77f93b
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+KOMPOSE_COMMIT="767ab4b"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${COMPOSE_KOMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}