summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-26 16:07:45 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-26 16:08:13 +0200
commit4752a49cec435dc014093123fbd2baab417d0f5f (patch)
treec128e9796918c803f2e0ae0c4f4b2eebc610e3d5 /app-emulation
parentprofiles: hard-mask server USE flag on dev-python/paramiko (diff)
downloadgentoo-4752a49cec435dc014093123fbd2baab417d0f5f.tar.gz
gentoo-4752a49cec435dc014093123fbd2baab417d0f5f.tar.bz2
gentoo-4752a49cec435dc014093123fbd2baab417d0f5f.zip
app-emulation/img: Version bump to 0.5.1
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.5.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index ba80778bcbd6..84d8bf9d96ea 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1,2 +1,3 @@
DIST img-0.4.8.tar.gz 5587652 BLAKE2B 5b74ff24e6f36674b66b3f87abe928a9d8c8361835eb61cb04ddfce6bfc7cb7b8e6e1f41d61d9f75c09c3646d0d697074882e1f7b87259b60d7c53303718e325 SHA512 fb5b97c4794798dc2dba5d4c9493da9708a55a9e5e7b2259585409c4e7973fecd362132dabb81c72f20b61956c5a8bc67b58db49c22e7ce56eaec784bbb51ca5
DIST img-0.4.9.tar.gz 4654821 BLAKE2B b3cd419aeb64ec8c2e8ee0fd523d387fd5b1a340ad61deec1e3fda59ba4e58e7594682aa49e04922e5bdcad4c458f23d4b8081784ba9d7d88dc953a0bd7c24a9 SHA512 c529affce023a8ae972a8526b48701d137edd3a8d5a22687269eec07864a1c30edf1c84bfea29cb7d166cc4fed4b0eb1e34e41d5d21be9d1a3b975b4c1bc678f
+DIST img-0.5.1.tar.gz 6394095 BLAKE2B 5c26487f721ef7157c8dc47c5abc2f4f296efe4ddf3b4e1e0513e4a2a71c96287e92c2332b340d583f0687ff7c3b1f10aea107f9ab1527b3f6760f1f359de867 SHA512 66f812da0b77882a610f4de849eaf473a0a6e964fff7cc0b596b46411aa33d625a376d3e829b8eb438e26d09624146c18b83a2289ddf2785024e3f8a6fee6cf9
diff --git a/app-emulation/img/img-0.5.1.ebuild b/app-emulation/img/img-0.5.1.ebuild
new file mode 100644
index 000000000000..c730376b7f9d
--- /dev/null
+++ b/app-emulation/img/img-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="671aaaa647a51cfd35f911e620fdd82d875403f5"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}