summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-26 12:00:34 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-26 12:02:42 -0500
commit482f930798ce03109dd63f9279735d336697ac3d (patch)
tree38016218515693582189420f56a928bff456d2e5 /app-emulation
parentapp-officeext/texmaths: Version bump (diff)
downloadgentoo-482f930798ce03109dd63f9279735d336697ac3d.tar.gz
gentoo-482f930798ce03109dd63f9279735d336697ac3d.tar.bz2
gentoo-482f930798ce03109dd63f9279735d336697ac3d.zip
app-emulation/open-vm-tools: patch -Werror out of configure.ac
This is less fragile than sed-ing all the Makefiles. Bug: https://bugs.gentoo.org/600886 Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/files/10.1.0-Werror.patch24
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild5
2 files changed, 25 insertions, 4 deletions
diff --git a/app-emulation/open-vm-tools/files/10.1.0-Werror.patch b/app-emulation/open-vm-tools/files/10.1.0-Werror.patch
new file mode 100644
index 000000000000..b79865e62db6
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/10.1.0-Werror.patch
@@ -0,0 +1,24 @@
+From fdf599994d58ef47b73dc94d21d3556a2ec5d9da Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 26 Nov 2016 11:54:33 -0500
+Subject: [PATCH] build: drop -Werror
+
+---
+ open-vm-tools/configure.ac | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/open-vm-tools/configure.ac b/open-vm-tools/configure.ac
+index 8d4604e8..4d925f22 100644
+--- a/open-vm-tools/configure.ac
++++ b/open-vm-tools/configure.ac
+@@ -1137,7 +1137,6 @@ AC_C_VOLATILE
+
+ ### General flags / actions
+ CFLAGS="$CFLAGS -Wall"
+-CFLAGS="$CFLAGS -Werror"
+
+ # -Wno-unknown-pragmas is due to gcc not understanding '#pragma ident'
+ # in Xlib.h on OpenSolaris.
+--
+2.11.0.rc2
+
diff --git a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
index a7835d2cb6ee..55c652f6f4b5 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-10.1.0.ebuild
@@ -49,7 +49,6 @@ COMMON_DEPEND="
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig
- sys-apps/findutils
"
RDEPEND="${COMMON_DEPEND}
@@ -60,6 +59,7 @@ S="${WORKDIR}/${MY_P}/open-vm-tools"
PATCHES=(
"${FILESDIR}/10.1.0-mount.vmhgfs.patch"
"${FILESDIR}/10.1.0-vgauth.patch"
+ "${FILESDIR}/10.1.0-Werror.patch"
)
pkg_setup() {
@@ -107,9 +107,6 @@ src_configure() {
)
econf "${myeconfargs[@]}"
-
- # Bugs 260878, 326761
- find . -name Makefile -exec sed -i -e 's/-Werror//g' '{}' + || die "sed out Werror failed"
}
src_compile() {