summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-10-29 11:04:31 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-10-29 11:34:39 +0100
commit4eeb3971eb856b8fdece1185f119a296d287cc2d (patch)
tree09183cdf5c0a321c6996b05f3857610a0c71d708 /app-emulation
parentkde-apps/marble: add dev-libs/quazip USE dependency (diff)
downloadgentoo-4eeb3971eb856b8fdece1185f119a296d287cc2d.tar.gz
gentoo-4eeb3971eb856b8fdece1185f119a296d287cc2d.tar.bz2
gentoo-4eeb3971eb856b8fdece1185f119a296d287cc2d.zip
app-emulation/dosemu: tweak to support non-bash '/bin/sh'
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild3
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild3
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-dash.patch10
3 files changed, 14 insertions, 2 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
index 83615529e1d3..5a56b8d95e3a 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20091009.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -35,6 +35,7 @@ S="${WORKDIR}/${PN}"
src_compile() {
epatch "${FILESDIR}"/${P}-flex.patch #437074
+ epatch "${FILESDIR}"/${P}-dash.patch
# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
index 10215903c61f..4f04b5dde367 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -45,6 +45,7 @@ S="${WORKDIR}/${PN}-code-${COMMIT}"
src_prepare() {
epatch "${FILESDIR}"/${P}-fortify.patch
+ epatch "${FILESDIR}"/${PN}-1.4.1_pre20091009-dash.patch
# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
diff --git a/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-dash.patch b/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-dash.patch
new file mode 100644
index 000000000000..c48712e68661
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.1_pre20091009-dash.patch
@@ -0,0 +1,10 @@
+Dash does not support 'echo -n' and breaks default config sourcing.
+diff --git a/default-configure b/default-configure
+index 9e4b78b..a749f63 100755
+--- a/default-configure
++++ b/default-configure
+@@ -30,3 +30,3 @@ done
+ CONF=`cat $CONF_FILE`
+-CONF=`echo -n "$CONF"| sed '/^config {/d' | sed '/^}/d' | tr '\n' ' ' `
++CONF=`printf "%s" "$CONF"| sed '/^config {/d' | sed '/^}/d' | tr '\n' ' ' `
+