summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-04-03 11:15:20 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-04-03 11:19:50 -0500
commit5735e27dbda375abe9887d4a4e902aed7c795e10 (patch)
tree6effc77e07cc48ad2f8e6594d6caef6efc196de0 /app-emulation
parentnet-analyzer/nagios-core: x86 stable wrt bug #715940 (diff)
downloadgentoo-5735e27dbda375abe9887d4a4e902aed7c795e10.tar.gz
gentoo-5735e27dbda375abe9887d4a4e902aed7c795e10.tar.bz2
gentoo-5735e27dbda375abe9887d4a4e902aed7c795e10.zip
app-emulation/buildah: 1.14.6 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.14.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index cdbcf5d2fdc3..1a8cb047bcf2 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -1 +1,2 @@
DIST buildah-1.14.5.tar.gz 11023227 BLAKE2B ebd6cecfc6fa4635ae662dddc722a350fd0b9c87c3d4d67f8010d5ea070270da4f4cd5759612b84d55ecd27b90904950b96471d75057bc6b7d45989312ebec8e SHA512 759d2ba26af43d6ff7ee891f88114a0cde6307439f7837343bfa6edba2473805f0f2e584264e8be01b9f0af07b1fd323243af5feeb9535ada4475ce53a980ff6
+DIST buildah-1.14.6.tar.gz 11104320 BLAKE2B fa618e095523e853454170504aa2747d29e8bec16282eb4bdcf9d8ddeccceeb7ad706d0d127dc621ef0840136737b328c31d9b6b2f9bd1b734beb6d24a15bea3 SHA512 869addbd41c115ca92eab30133c76cd0d449184e95f3b64fa57ad84f50834e6f6189bd1a7e4871aba270b96bf69192ff00da7f0e086439c811c5093342ac14d2
diff --git a/app-emulation/buildah/buildah-1.14.6.ebuild b/app-emulation/buildah/buildah-1.14.6.ebuild
new file mode 100644
index 000000000000..fe2402a5756a
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.14.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT=09cce629
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ emake GIT_COMMIT=${GIT_COMMIT} all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}