summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2019-03-03 18:22:27 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-03-11 11:13:33 +0100
commit5d4db6512cd74d5c6e38a864de74a3ca47b97e1d (patch)
treee9c8ff960f06292db655c55baa2b8a05f8b35f25 /app-emulation
parentvirtual/notification-daemon: depend on x11-wm/awesome[dbus]. (diff)
downloadgentoo-5d4db6512cd74d5c6e38a864de74a3ca47b97e1d.tar.gz
gentoo-5d4db6512cd74d5c6e38a864de74a3ca47b97e1d.tar.bz2
gentoo-5d4db6512cd74d5c6e38a864de74a3ca47b97e1d.zip
app-emulation/punes: version bump to 0.103.
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11232 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/punes/Manifest1
-rw-r--r--app-emulation/punes/punes-0.103.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/punes/Manifest b/app-emulation/punes/Manifest
index d97710438994..146ce82d3567 100644
--- a/app-emulation/punes/Manifest
+++ b/app-emulation/punes/Manifest
@@ -1 +1,2 @@
DIST punes-0.102.tar.gz 4670534 BLAKE2B 04576110e4fcd9aeaa3dfb6812ab7a21305200c82651be00defcb59b91374b155b279818f2e09d217841aa8567c41e06067252538fb68b7b907d5ab29b02c678 SHA512 dff95b25f64ed03060b6dd187d7a283acfddb6bea4168df5be4d309bd6aabdcaa5d0ea0312d0824205bf134cd0ddabf014e82a81c8a901a59258475ec24bd394
+DIST punes-0.103.tar.gz 5366838 BLAKE2B cb4a9a1336293891e06d573f68c52962e79220e7024fad716a957f5423a72703a34efc3fb6129dbe9ffde2c96fe7abd2a1ad4a622aaca89e90f6a2d5af8c1a53 SHA512 db0fbc075b9fd46be8013b17c03fd7abd12b209ce166557c83283c917e53224712ba5838cd8b9e7fad3d21271f29e475460996dd9800b9f759602e289bad4205
diff --git a/app-emulation/punes/punes-0.103.ebuild b/app-emulation/punes/punes-0.103.ebuild
new file mode 100644
index 000000000000..a12d37ba11e8
--- /dev/null
+++ b/app-emulation/punes/punes-0.103.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools xdg-utils
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ media-libs/alsa-lib
+ virtual/opengl"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/puNES-${PV}"
+
+src_prepare() {
+ default
+
+ sed -i "/update-desktop-database/d" misc/Makefile.am || die
+ eautoreconf
+ # FIXME why eautoreconf can't handle this?
+ cd "src/extra/lib7zip-1.6.5" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cg opengl-nvidia-cg)
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}