summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-05-31 12:46:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-05-31 12:46:56 +0200
commit66d3235c9e4ad2a2e8cf398d6e339502ed1241cf (patch)
tree45e0a62aa02ded0a53faeb3a3cf067f70b665f45 /app-emulation
parentnet-analyzer/wireshark: stable 2.6.1 for ia64, bug #656806 (diff)
downloadgentoo-66d3235c9e4ad2a2e8cf398d6e339502ed1241cf.tar.gz
gentoo-66d3235c9e4ad2a2e8cf398d6e339502ed1241cf.tar.bz2
gentoo-66d3235c9e4ad2a2e8cf398d6e339502ed1241cf.zip
app-emulation/reg: Initial version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/reg/Manifest1
-rw-r--r--app-emulation/reg/metadata.xml11
-rw-r--r--app-emulation/reg/reg-0.13.0.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/reg/Manifest b/app-emulation/reg/Manifest
new file mode 100644
index 000000000000..170f7bd31bd1
--- /dev/null
+++ b/app-emulation/reg/Manifest
@@ -0,0 +1 @@
+DIST reg-0.13.0.tar.gz 14958008 BLAKE2B 7afdb3f00732ad3fe4e8581d0773ba3d8ed4e9d41704e5aec7e45f16e407d19cc30cf8d4461d32719200b0253d26b609ff641c760b220685edb98bfb49f9b6b6 SHA512 7b9c23de23b798e9da4902a00d965c62452997240f53980eda478c8fa59ade985ca2f25fbe902597bcb32440dfcd41bd72c4631b4f4be956a48b75875e134018
diff --git a/app-emulation/reg/metadata.xml b/app-emulation/reg/metadata.xml
new file mode 100644
index 000000000000..e08ad1ff9a01
--- /dev/null
+++ b/app-emulation/reg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">genuinetools/reg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/reg/reg-0.13.0.ebuild b/app-emulation/reg/reg-0.13.0.ebuild
new file mode 100644
index 000000000000..f7c9db927029
--- /dev/null
+++ b/app-emulation/reg/reg-0.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="b2cdf0428ddc051f8a39143b63311b515e26d012"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+}