summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-06 14:26:23 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-06 14:26:23 +0200
commit6fe499c33bb54affdb427eaa3914191229171b7c (patch)
treea26df7684355e91f7fe993458a46644a101ce532 /app-emulation
parentapp-crypt/cfssl: Remove old (diff)
downloadgentoo-6fe499c33bb54affdb427eaa3914191229171b7c.tar.gz
gentoo-6fe499c33bb54affdb427eaa3914191229171b7c.tar.bz2
gentoo-6fe499c33bb54affdb427eaa3914191229171b7c.zip
app-emulation/docker-compose: Version bump to 1.21.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.21.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index fa5ebe616cdb..d0adb2aa4ece 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -2,3 +2,4 @@ DIST docker-compose-1.18.0.tar.gz 231256 BLAKE2B be9b57dd89a81734b850f61622a924a
DIST docker-compose-1.19.0.tar.gz 238307 BLAKE2B 2a7bbcf50c2cc591eba1d59db30cb0341e33e3f1ebe948e0b6762d9bffcdcc72d98e2da19fc549c5fabda192fca69a9d54e016601ddb4f4a94f0dc1c93f99a29 SHA512 f1d522621580a5130378508e6b15ad2e4708e9c5ff713627ca54308ab3e6bf000e21c55bbdf9585b2116e73648fdc773500a5415ab81a72dd2c69c9c07e71581
DIST docker-compose-1.20.1.tar.gz 246159 BLAKE2B 32836f06239d6f1506ecebac48c8b56c58620d0ba309b8469c073ec3b048bf3743afb1ff6f63d2031df4bb316191d9cd32d5cf85a2cb86544254c6054a7dd502 SHA512 faba24ea501c4e4aaf04bddf1d498eaa7702385458ac7a41f6054e9153f9e03e1e6f50aebc5156d6a814d567aedea1d16ff532872a1765bbabbd3c8da47e36e0
DIST docker-compose-1.21.0.tar.gz 250262 BLAKE2B e27c6a24d9f02a6746e53d42845424d3c2eef0a816106a988a1eb7dfdc7ea39b1025afb6a4bc361bc97af501af554cb4b34ab62c150e500620c3256074d69a44 SHA512 1926abbb67508216312880f3f0ad7a752760f324a0d17548ecefa924f571896a55a7fc5d174f6ef3ede314c488dec8a7edbccdc399eea6d34459cb812cf103ac
+DIST docker-compose-1.21.2.tar.gz 294070 BLAKE2B c27ce8708f20385ee3f072c4aa832a42dc975d08d71d9e61ce3a822055d606db7e1e7b6e182523e64115922416d5c1baeca14897a241e84873a97aa755bce539 SHA512 6392582d8c6c321458b1163336f1c902548cc250f9ab5b765d144287b006ef6dacdc47199fafbb6efe426e382325b94986aa159df08dec4974a71968862a8435
diff --git a/app-emulation/docker-compose/docker-compose-1.21.2.ebuild b/app-emulation/docker-compose/docker-compose-1.21.2.ebuild
new file mode 100644
index 000000000000..2e64dd53e966
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.21.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://www.docker.com/"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/cached-property-2[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.2.1[${PYTHON_USEDEP}]
+ <dev-python/docker-py-4.0[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ <dev-python/docopt-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
+ !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ <dev-python/PySocks-2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.19[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9[${PYTHON_USEDEP}]
+ <dev-python/texttable-0.10[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}