summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-26 05:54:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-26 06:10:10 -0400
commit75a47c9ad60d5c50cd247a8c6771597f9d1d75a9 (patch)
tree5bb5e80e4d77ba876c2ffcf772ab4d41ee648d30 /app-emulation
parentapp-emulation/dxvk: update -mno-avx comment to match wine (diff)
downloadgentoo-75a47c9ad60d5c50cd247a8c6771597f9d1d75a9.tar.gz
gentoo-75a47c9ad60d5c50cd247a8c6771597f9d1d75a9.tar.bz2
gentoo-75a47c9ad60d5c50cd247a8c6771597f9d1d75a9.zip
app-emulation/vkd3d-proton: import -mno-avx from dxvk's ebuild
Not known to have caused issues with vkd3d-proton in particular (so skipping revbump), but believed to be too unsafe at the moment and should use it at least for future rebuilds/bumps. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild6
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild6
4 files changed, 24 insertions, 0 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 2e3e5c86e2ce..3c960bc15b97 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -100,6 +100,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
index 9acb9d5109a0..cd727dfb9b35 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
index 48d90c5020cc..e51d2c12d6be 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.9.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 3b7c91df0a13..3aa61a026157 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -105,6 +105,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL