summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2017-10-16 14:32:44 +0200
committerYixun Lan <dlan@gentoo.org>2017-10-17 15:24:31 +0800
commit75c8666ff431784afbfd419e0f2362fc293a4117 (patch)
treea53f2beeb1d86ca4619a7e93f4fa1d8d2ebf8a2a /app-emulation
parentapp-emulation/xen-tools: fix bashism (diff)
downloadgentoo-75c8666ff431784afbfd419e0f2362fc293a4117.tar.gz
gentoo-75c8666ff431784afbfd419e0f2362fc293a4117.tar.bz2
gentoo-75c8666ff431784afbfd419e0f2362fc293a4117.zip
app-emulation/xen-tools: add openrc init for xen-watchdog
Closes: https://github.com/gentoo/gentoo/pull/5962 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/files/xen-watchdog.initd6
-rw-r--r--app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild1
2 files changed, 7 insertions, 0 deletions
diff --git a/app-emulation/xen-tools/files/xen-watchdog.initd b/app-emulation/xen-tools/files/xen-watchdog.initd
new file mode 100644
index 000000000000..6fbc54dfb2fa
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-watchdog.initd
@@ -0,0 +1,6 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/xenwatchdogd"
+command_args="30 15"
diff --git a/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild b/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
index 1aac5f357a39..3de1759592f9 100644
--- a/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.8.2-r2.ebuild
@@ -421,6 +421,7 @@ src_install() {
newconfd "${FILESDIR}"/xencommons.confd xencommons
newinitd "${FILESDIR}"/xenqemudev.initd xenqemudev
newconfd "${FILESDIR}"/xenqemudev.confd xenqemudev
+ newinitd "${FILESDIR}"/xen-watchdog.initd xen-watchdog
if use screen; then
cat "${FILESDIR}"/xendomains-screen.confd >> "${D}"/etc/conf.d/xendomains || die