summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-05-25 11:53:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-05-25 11:54:02 -0500
commit7ad7b6e8b13bd22cd134642c7a84c94cff9224db (patch)
treefef4e663faeccc964ee6aefde66357e06bfc0971 /app-emulation
parentmedia-sound/mp3blaster: Bump to 3.2.6 (diff)
downloadgentoo-7ad7b6e8b13bd22cd134642c7a84c94cff9224db.tar.gz
gentoo-7ad7b6e8b13bd22cd134642c7a84c94cff9224db.tar.bz2
gentoo-7ad7b6e8b13bd22cd134642c7a84c94cff9224db.zip
app-emulation/diskimage-builder: bup 2.4.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.4.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 3dafdcb2c813..46b7724b377c 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,3 +1,4 @@
DIST diskimage-builder-1.28.0.tar.gz 267409 SHA256 2d8999a8484d27e8604d125aabcbdad648f8b601776225cfc611faf1a3b9a0e6 SHA512 ae13e29563f90a4aaa4f2bee889bca4fd662da41fcffb957ca8a4380907e5d89fbc25ecb93aeda2cb5597776b51417388e8a5e39741250d68a8f7f67239ebc7f WHIRLPOOL 7cfcefcf37fd0d5fae4fb8d3284ad3b60e53e4a2853c85625a1925c34bd4cdbee999932089f7dae81adcf699226ba1550f729a2b1b8aab4b6e54c10c7148fea1
DIST diskimage-builder-2.3.3.tar.gz 294768 SHA256 227943d8702a66c9ed08d59362324bc79951ad7c11d9efdb67c32b2fbd517af2 SHA512 d3e97ef520270d056877bef467d9fb4bb8bd64ebff149ca7e8a5b11e5f19043a93932968d61b7efe7e54767dc88e04536ceb8b664e9c40ab388eac52303e2a74 WHIRLPOOL c780d3de0bcc43e35b5b12bbd188eece079467eec5ea7a426450d30f14135cdd4fe82985804514c1382424aae41534af37c163e55de98031d3327d89743a3a2b
DIST diskimage-builder-2.4.0.tar.gz 308467 SHA256 ae9bc8b0dde17d422785d0099152997a15a4c051c484f3efff17594d8bb8d34c SHA512 2936d88f13dcebe67133400c20fa355349c33eb1d89045c38ffa4c2942152d9ca4b7fadefa622bf1c0055f8903a68d958f3b3db21fb3472da7b6ec7fd5c01267 WHIRLPOOL 6cd869d5a8fd31e3aa154d76eaa2543644c254eb90b12df80ce649c331759fbc5e4c8912a7753099a32c15c6dc98db256080d02d16e1d1d82377b293a7af49f0
+DIST diskimage-builder-2.4.1.tar.gz 304969 SHA256 9a01eabc73bde93da3fde598249cc273c6cc744e8e6b850a0f7dd7e69c076543 SHA512 32ef8b7cae08c90691256be4b8b65c986de00306d935919c7d9ecba21722534da8bb00ab887b810bfff35e60c1e943641de576a7c4b29a6ff3d15315b55fb307 WHIRLPOOL a4e9a30452e2e0785e371968d463a95a04d5e9a7316decc2a00e27038b3606ca03515535b76e721eb12b8072567c91f9a6372d780fb60ab983d81071f88974e4
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.4.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.4.1.ebuild
new file mode 100644
index 000000000000..cd53f33866bb
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"