summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-04-18 14:28:23 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-04-18 14:28:23 -0500
commit8b8e82850dc8818b97f8bafc3ccc7982142f1cea (patch)
tree33d47572fa819b846e485e848d0053fd7728ec39 /app-emulation
parentapp-emulation/spice-vdagent: glorious version bump (diff)
downloadgentoo-8b8e82850dc8818b97f8bafc3ccc7982142f1cea.tar.gz
gentoo-8b8e82850dc8818b97f8bafc3ccc7982142f1cea.tar.bz2
gentoo-8b8e82850dc8818b97f8bafc3ccc7982142f1cea.zip
app-emulation/qemu-guest-agent: fix shutdown command
Closes: https://bugs.gentoo.org/681874 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-guest-agent/files/qemu-guest-agent-4.2.0-fix-shutdown.patch11
-rw-r--r--app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0-r1.ebuild (renamed from app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0.ebuild)1
2 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/qemu-guest-agent/files/qemu-guest-agent-4.2.0-fix-shutdown.patch b/app-emulation/qemu-guest-agent/files/qemu-guest-agent-4.2.0-fix-shutdown.patch
new file mode 100644
index 000000000000..f69781694f1d
--- /dev/null
+++ b/app-emulation/qemu-guest-agent/files/qemu-guest-agent-4.2.0-fix-shutdown.patch
@@ -0,0 +1,11 @@
+--- qemu-4.2.0/qga/commands-posix.c.orig 2020-03-23 11:15:05.972610989 +0300
++++ qemu-4.2.0/qga/commands-posix.c 2020-03-23 11:15:39.676015087 +0300
+@@ -108,7 +108,7 @@
+ reopen_fd_to_null(1);
+ reopen_fd_to_null(2);
+
+- execle("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
++ execle("/sbin/shutdown", "shutdown", "-h", "now", shutdown_flag, "+0",
+ "hypervisor initiated shutdown", (char*)NULL, environ);
+ _exit(EXIT_FAILURE);
+ } else if (pid < 0) {
diff --git a/app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0.ebuild b/app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0-r1.ebuild
index 27782cf6ca5a..c290b1251ca0 100644
--- a/app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0.ebuild
+++ b/app-emulation/qemu-guest-agent/qemu-guest-agent-4.2.0-r1.ebuild
@@ -29,6 +29,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-4.2.0-sysmacros.patch #580924
+ "${FILESDIR}"/${PN}-4.2.0-fix-shutdown.patch #681874
)
src_configure() {