summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-13 05:46:54 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-13 06:32:49 -0500
commita0dc96d04835be7ab84fe3c946928cec93266fa7 (patch)
treea4e74b523677ea0cae07cfe6ce6c9a71ada275ac /app-emulation
parentx11-terms/kitty: drop 0.27.0 (diff)
downloadgentoo-a0dc96d04835be7ab84fe3c946928cec93266fa7.tar.gz
gentoo-a0dc96d04835be7ab84fe3c946928cec93266fa7.tar.bz2
gentoo-a0dc96d04835be7ab84fe3c946928cec93266fa7.zip
app-emulation/wine-staging: migrate to patchinstall.py
Upstream has deprecated the old shell script and (finally) ported patchinstall.py to python3. So let's use what's intended. Unfortunately means no more "eapply" integration, will either use git to apply patches or fallback to hacks (latter may need testing in non-live, albeit the whole machinery is not useful right now given binary patches haven't been used for a while). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 887f0e540454..d6afdde72ae8 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit autotools flag-o-matic multilib multilib-build toolchain-funcs wrapper
+PYTHON_COMPAT=( python3_{9..11} )
+inherit autotools edo flag-o-matic multilib multilib-build
+inherit python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.3
WINE_MONO=7.4.0
@@ -110,7 +112,16 @@ DEPEND="
${WINE_COMMON_DEPEND}
sys-kernel/linux-headers
X? ( x11-base/xorg-proto )"
+# gitapply.sh prefers git but can fallback to patch+extras
BDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ dev-vcs/git
+ (
+ sys-apps/gawk
+ sys-apps/util-linux
+ )
+ )
dev-lang/perl
sys-devel/binutils
sys-devel/bison
@@ -164,19 +175,14 @@ src_unpack() {
}
src_prepare() {
- local staging=(
- ./patchinstall.sh DESTDIR="${S}"
+ local patchinstallargs=(
--all
- --backend=eapply
--no-autoconf
-W winemenubuilder-Desktop_Icon_Path #652176
${MY_WINE_STAGING_CONF}
)
- # source patcher in a subshell so can use eapply as a backend
- ebegin "Running ${staging[*]}"
- ( cd ../${P}/patches && . "${staging[@]}" )
- eend ${?} || die "Failed to apply the patchset"
+ edo "${PYTHON}" ../${P}/staging/patchinstall.py "${patchinstallargs[@]}"
# sanity check, bumping these has a history of oversights
local geckomono=$(sed -En '/^#define (GECKO|MONO)_VER/{s/[^0-9.]//gp}' \