summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-01-04 16:54:01 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-01-04 17:06:56 -0600
commita6fa38e72cbaf608a442f8d4f37601a8696de3bc (patch)
treea9bbc871761f221244c90ed04577b3984e418cf2 /app-emulation
parentapp-emulation/containerd: 1.4.3 bump (diff)
downloadgentoo-a6fa38e72cbaf608a442f8d4f37601a8696de3bc.tar.gz
gentoo-a6fa38e72cbaf608a442f8d4f37601a8696de3bc.tar.bz2
gentoo-a6fa38e72cbaf608a442f8d4f37601a8696de3bc.zip
app-emulation/runc: 1.0.0-rc92 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/runc/Manifest1
-rw-r--r--app-emulation/runc/runc-1.0.0_rc92.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-emulation/runc/Manifest b/app-emulation/runc/Manifest
index 0c5009ddfbe3..53f31a4e4933 100644
--- a/app-emulation/runc/Manifest
+++ b/app-emulation/runc/Manifest
@@ -1 +1,2 @@
DIST runc-1.0.0_rc10.tar.gz 1929802 BLAKE2B 8399c3d62726bbb6256efef7e15b7496a7172bf25170b12beb60be498967dec4fde2aebd073de4265e132ff864bafc4d2499ab677390a4f7c0a1605d83ae55e5 SHA512 598221071ef07d18bf34bf5d5c68b8ad78ee71716177fc3ce5b6909cd841d5aed93f17ebf1f3d134707d29eef1f54a4ddc21e79621a9bd957df28a8d2e028ab7
+DIST runc-1.0.0_rc92.tar.gz 2061469 BLAKE2B 06444eaf7602fe9ddaf7728c7f55bd718d1fe8f5f0ce6b21abc49a1d84eaa2fc3550d0d275ba5548ee9ebb6948a8ed415de8562a990d6085d1da8fb37e46afb9 SHA512 770a31736f5ab4ba359d91bd236750511f90b29af0af2bad5c238b611f465d7302e78b57ce8a702068440fda2d74588b92fd4d24c6d34e6fc1bd649ea3d8ee40
diff --git a/app-emulation/runc/runc-1.0.0_rc92.ebuild b/app-emulation/runc/runc-1.0.0_rc92.ebuild
new file mode 100644
index 000000000000..2a192400ef49
--- /dev/null
+++ b/app-emulation/runc/runc-1.0.0_rc92.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module linux-info
+
+# update on bump, look for https://github.com/docker\
+# docker-ce/blob/<docker ver OR branch>/components/engine/hack/dockerfile/install/runc.installer
+RUNC_COMMIT=ff819c7e9184c13b7c2607fe6c30ae19403a7aff
+CONFIG_CHECK="~USER_NS"
+
+DESCRIPTION="runc container cli tools"
+HOMEPAGE="http://runc.io"
+MY_PV="${PV/_/-}"
+SRC_URI="https://github.com/opencontainers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="apparmor +ambient hardened +kmem +seccomp selinux test"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+
+RDEPEND="
+ ${DEPEND}
+ !app-emulation/docker-runc
+ apparmor? ( sys-libs/libapparmor )
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ test? ( "${RDEPEND}" )
+"
+
+# tests need busybox binary, and portage namespace
+# sandboxing disabled: mount-sandbox pid-sandbox ipc-sandbox
+# majority of tests pass
+RESTRICT+=" test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # build up optional flags
+ local options=(
+ $(usev ambient)
+ $(usev apparmor)
+ $(usev seccomp)
+ $(usev selinux)
+ $(usex kmem '' 'nokmem')
+ )
+
+ myemakeargs=(
+ BINDIR="${ED}/usr/bin"
+ BUILDTAGS="${options[*]}"
+ COMMIT=${RUNC_COMMIT}
+ DESTDIR="${ED}"
+ PREFIX="${ED}/usr"
+ )
+
+ emake "${myemakeargs[@]}" runc man
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install install-man install-bash
+
+ local DOCS=( README.md PRINCIPLES.md docs/. )
+ einstalldocs
+}
+
+src_test() {
+ emake "${myemakeargs[@]}" localunittest
+}