summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-07-21 21:57:11 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-07-21 21:57:11 +0100
commitae382121d9a659aadea4f37a0a44c338f091ab2f (patch)
tree56fcedda9e8c988fbcba4b4e6b868acf8764152c /app-emulation
parentapp-emulation/fs-uae: Version bump to 3.0.0 (diff)
downloadgentoo-ae382121d9a659aadea4f37a0a44c338f091ab2f.tar.gz
gentoo-ae382121d9a659aadea4f37a0a44c338f091ab2f.tar.bz2
gentoo-ae382121d9a659aadea4f37a0a44c338f091ab2f.zip
app-emulation/fs-uae-launcher: Version bump to 3.0.0
Package-Manager: Portage-2.3.69, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/files/fs-uae-launcher-3.0.0-ROMs.patch14
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.0.0.ebuild77
3 files changed, 92 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 694c0d62d899..b317a132289f 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1 +1,2 @@
DIST fs-uae-launcher-2.8.3.tar.gz 8784242 BLAKE2B e54f73efde6563d9e4ab6b4f57cc73bca80d72d0ded4db67edc53dc344685889abf485df067541e8d635595ac5457ec456ded0306310b1ad95a3b3ef07e53bc3 SHA512 4eaa5979fe2e8f2c792d4878e9a9ad0a0433206aac42aa380d97aee21e4ba29a54caced2437b83357c2c4d2fab121bfb821fdb8a883ead971766866b02067a2d
+DIST fs-uae-launcher-3.0.0.tar.gz 9631352 BLAKE2B dc2f940cbde1fe9d2386e512bf5c0ca9a4ea19332826095cc5ba95e90c7f6cfaf0cd5dbaa692c192ac7d74a3ddf245062a0faeeccc9d8a135e544d304119e239 SHA512 76f9c48d2a46ece38aebb318a6d684ff40e85fef76bcc6ac57c7f397c828dae45541ba458a7792f102a8afc69a4183b9932b637318716a8b40ff3dbd3b37cad7
diff --git a/app-emulation/fs-uae-launcher/files/fs-uae-launcher-3.0.0-ROMs.patch b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-3.0.0-ROMs.patch
new file mode 100644
index 000000000000..44427642253f
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-3.0.0-ROMs.patch
@@ -0,0 +1,14 @@
+diff -Naur a/fsgs/amiga/roms.py b/fsgs/amiga/roms.py
+--- a/fsgs/amiga/roms.py 2019-06-21 17:49:42.000000000 +0100
++++ b/fsgs/amiga/roms.py 2019-07-21 21:42:14.135600616 +0100
+@@ -10,7 +10,9 @@
+ # amiga-os-130.rom (decrypted, patched)
+ # Kickstart v1.3 r34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[!]
+ # Kickstart v1.3 r34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[o] (patch)
+- "891e9a547772fe0c6c19b610baf8bc4ea7fcb785"
++ "891e9a547772fe0c6c19b610baf8bc4ea7fcb785",
++ # kick13.rom - from Upgrade Commodore Amiga 500 (1989)
++ "90933936cce43ca9bc6bf375662c076b27e3c458",
+ ]
+
+ A500_1_2_KICKSTARTS = [
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.0.0.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.0.0.ebuild
new file mode 100644
index 000000000000..62652d3eb997
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/stable/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lha"
+
+RDEPEND="
+ app-emulation/fs-uae
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+"
+
+DEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ROMs.patch
+ "${FILESDIR}"/${PN}-2.8.3-QApplication.patch
+)
+
+src_prepare() {
+ default
+
+ # Unbundle OpenGL library. Keep oyoyo IRC library because upstream
+ # is long dead and it's not worth packaging separately.
+ rm -r OpenGL || die
+ sed -i -r "/OpenGL/d" setup.py || die
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ local dir=${EPREFIX}/usr/share/${PN}
+ distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+
+ emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+ elog "Some important information:"
+ elog
+ ewarn " - Do not use QtCurve, it will crash PyQt5!"
+ elog
+ elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+ elog " If your Documents directory is not configured according to the XDG"
+ elog " user diretory spec, ~/FS-UAE will be used as a fallback."
+ elog
+ elog " - You can override this by putting the path to the desired base"
+ elog " directory in a special config file. The config file will be read"
+ elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+ elog " if it exists."
+ elog
+ elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+ elog " --base-dir=/path/to/desired/dir"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }