summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-16 05:31:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-16 05:50:45 -0500
commitbd830da1d6808098a20bffd01559cbda993b95b4 (patch)
tree32b9f410403bbf7ecdb1287fce7cf38ac2480d1d /app-emulation
parentapp-emulation/wine-vanilla: optfeature on game-device-udev-rules (diff)
downloadgentoo-bd830da1d6808098a20bffd01559cbda993b95b4.tar.gz
gentoo-bd830da1d6808098a20bffd01559cbda993b95b4.tar.bz2
gentoo-bd830da1d6808098a20bffd01559cbda993b95b4.zip
app-emulation/wine-staging: optfeature on game-device-udev-rules
In 9.1+, wine defaults to using /dev/hidraw* for some extra gamepads, most notably Sony DualShock4 which may come as unexpected. /dev/hidraw* access is restricted to root by default leaving users with a situation that seem like a wine regression. Only a optfeature since most gamepads do not need this (xbox one, about any 3rd party gamepads, etc...). Hopefully the optfeature is noticed by affected users. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9.1.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9.2.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9.1.ebuild b/app-emulation/wine-staging/wine-staging-9.1.ebuild
index f9096affab24..4ec95df08d29 100644
--- a/app-emulation/wine-staging/wine-staging-9.1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools edo flag-o-matic multilib multilib-build
+inherit autotools edo flag-o-matic optfeature multilib multilib-build
inherit prefix python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.4
@@ -461,6 +461,9 @@ pkg_postinst() {
ewarn "applications under ${PN} will likely not be usable."
fi
+ optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
+ games-util/game-device-udev-rules
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-staging/wine-staging-9.2.ebuild b/app-emulation/wine-staging/wine-staging-9.2.ebuild
index 9790d6480e7e..6b83fcb60f31 100644
--- a/app-emulation/wine-staging/wine-staging-9.2.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools edo flag-o-matic multilib multilib-build
+inherit autotools edo flag-o-matic optfeature multilib multilib-build
inherit prefix python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.4
@@ -461,6 +461,9 @@ pkg_postinst() {
ewarn "applications under ${PN} will likely not be usable."
fi
+ optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
+ games-util/game-device-udev-rules
+
eselect wine update --if-unset || die
}
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 9790d6480e7e..6b83fcb60f31 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools edo flag-o-matic multilib multilib-build
+inherit autotools edo flag-o-matic optfeature multilib multilib-build
inherit prefix python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.4
@@ -461,6 +461,9 @@ pkg_postinst() {
ewarn "applications under ${PN} will likely not be usable."
fi
+ optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
+ games-util/game-device-udev-rules
+
eselect wine update --if-unset || die
}