summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-13 09:49:11 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-13 09:52:40 -0700
commitc369c88e9ba3e1c18740fa6d705b9a078d67c254 (patch)
treeaeb23fd9109071a6a5378ed29d7633465358b8c8 /app-emulation
parentdev-python/sqlalchemy-migrate: 0.12.0 bump (diff)
downloadgentoo-c369c88e9ba3e1c18740fa6d705b9a078d67c254.tar.gz
gentoo-c369c88e9ba3e1c18740fa6d705b9a078d67c254.tar.bz2
gentoo-c369c88e9ba3e1c18740fa6d705b9a078d67c254.zip
app-emulation/libpod: version bump to 1.1.2
Reported-by: Dennis Schridde <devurandom@gmx.net> Closes: https://bugs.gentoo.org/680228 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libpod/Manifest1
-rw-r--r--app-emulation/libpod/libpod-1.1.2.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/app-emulation/libpod/Manifest b/app-emulation/libpod/Manifest
index 75ea1c1bff53..ce3196b69d47 100644
--- a/app-emulation/libpod/Manifest
+++ b/app-emulation/libpod/Manifest
@@ -1,2 +1,3 @@
DIST libpod-0.12.1.2.tar.gz 5987875 BLAKE2B 11381c53e768c94bfadcb2013a028f64058b0001cd985ef289d1618163225cdf10bd608cff0cd6f7fc1c094497184fc6d0cedea32fde54f3581ebb51eb5eabdd SHA512 9abb46d7880c4577d22b48aed01baeae29662dc3dbbdbc297f1eebe8324fb734d9bac6cd105dc93f7600753874c0fa581142d1b16f7490175cea80b8f62b34ce
DIST libpod-1.0.1.tar.gz 6088749 BLAKE2B 64e28c6c7b60e226cae6a302e6e26ca5c2659d3c61910cc6fd2bbceec20485d7f2106d32da0472bc18a08bd611a6f0bf851b5c46066b47613783768c53a4c034 SHA512 23515fa3934ba2ec174011362ab1b67c747a7bf3122e606677ed40eb18aad28f79da30d09b6e1d0b74384286ff600fd1441fa4b6424e8bf3e410e867b57d92ef
+DIST libpod-1.1.2.tar.gz 7878228 BLAKE2B 8974949843c6f966d48715df320e47b814e442e374e1393dd5a116c6f7222e9ce29f480205f6a58e213e6cead58e5b4f31fd776865911b22e517607349654d35 SHA512 55456fe03da0873d3f6c67ced25dbe98f6a5a14c3da64ab2b4a9c6161c1d727ec8cdfe5414b534531e440e8c86f909449f4026d66898b909924aba1744ec0682
diff --git a/app-emulation/libpod/libpod-1.1.2.ebuild b/app-emulation/libpod/libpod-1.1.2.ebuild
new file mode 100644
index 000000000000..0d80616d4c55
--- /dev/null
+++ b/app-emulation/libpod/libpod-1.1.2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="0ad9b6bf2aea4ba37e8c9738feabec61343ba175"
+EGO_PN="github.com/containers/${PN}"
+
+inherit golang-vcs-snapshot systemd
+
+DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
+HOMEPAGE="https://github.com/containers/libpod/"
+SRC_URI="https://github.com/containers/libpod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="apparmor btrfs ostree +rootless selinux"
+REQUIRED_USE="!selinux? ( !ostree )"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ app-crypt/gpgme:=
+ >=app-emulation/cri-o-1.13.0
+ >=app-emulation/runc-1.0.0_rc6
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:=
+ sys-fs/lvm2
+ sys-libs/libseccomp:=
+
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( sys-fs/btrfs-progs )
+ ostree? (
+ dev-libs/glib:=
+ dev-util/ostree:=
+ )
+ rootless? ( app-emulation/slirp4netns )
+ selinux? ( sys-libs/libselinux:= )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+
+ # Disable installation of python modules here, since those are
+ # installed by separate ebuilds.
+ sed -e '/^GIT_.*/d' \
+ -e 's/$(GO) build/$(GO) build -v -work -x/' \
+ -e 's/^\(install:.*\) install\.python$/\1/' \
+ -i Makefile || die
+}
+
+src_compile() {
+ [[ -f hack/apparmor_tag.sh ]] || die
+ if use apparmor; then
+ echo -e "#!/bin/sh\necho apparmor" > hack/apparmor_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/apparmor_tag.sh || die
+ fi
+
+ [[ -f hack/btrfs_installed_tag.sh ]] || die
+ if use btrfs; then
+ echo -e "#!/bin/sh\ntrue" > hack/btrfs_installed_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+ hack/btrfs_installed_tag.sh || die
+ fi
+
+ [[ -f hack/ostree_tag.sh ]] || die
+ if use ostree; then
+ echo -e "#!/bin/sh\necho ostree" > hack/ostree_tag.sh || die
+ else
+ echo -e "#!/bin/sh\necho containers_image_ostree_stub" > hack/ostree_tag.sh || die
+ fi
+
+ [[ -f hack/selinux_tag.sh ]] || die
+ if use selinux; then
+ echo -e "#!/bin/sh\necho selinux" > hack/selinux_tag.sh || die
+ else
+ echo -e "#!/bin/sh\ntrue" > hack/selinux_tag.sh || die
+ fi
+
+ env -u GOCACHE -u LDFLAGS -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+ emake all \
+ GIT_BRANCH=master \
+ GIT_BRANCH_CLEAN=master \
+ COMMIT_NO="${EGIT_COMMIT}" \
+ GIT_COMMIT="${EGIT_COMMIT}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install
+
+ insinto /etc/containers
+ newins test/registries.conf registries.conf.example
+ newins test/policy.json policy.json.example
+
+ newinitd "${FILESDIR}"/podman.initd podman
+
+ systemd_dounit "${S}"/contrib/varlink/*.service "${S}"/contrib/varlink/*.socket
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/podman.logrotated" podman
+
+ keepdir /var/lib/containers
+}
+
+pkg_preinst() {
+ LIBPOD_ROOTLESS_UPGRADE=false
+ if use rootless; then
+ has_version 'app-emulation/libpod[rootless]' || LIBPOD_ROOTLESS_UPGRADE=true
+ fi
+}
+
+pkg_postinst() {
+ local want_newline=false
+ if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
+ elog "You need to create the following config files:"
+ elog "/etc/containers/registries.conf"
+ elog "/etc/containers/policy.json"
+ elog "To copy over default examples, use:"
+ elog "cp /etc/containers/registries.conf{.example,}"
+ elog "cp /etc/containers/policy.json{.example,}"
+ want_newline=true
+ fi
+ if [[ ${LIBPOD_ROOTLESS_UPGRADE} == true ]] ; then
+ ${want_newline} && elog ""
+ elog "For rootless operation, you need to configure subuid/subgid"
+ elog "for user running podman. In case subuid/subgid has only been"
+ elog "configured for root, run:"
+ elog "usermod --add-subuids 1065536-1131071 <user>"
+ elog "usermod --add-subgids 1065536-1131071 <user>"
+ want_newline=true
+ fi
+}