summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-11-17 00:11:56 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-11-17 00:13:42 -0500
commitc4e8357dc253dc1de4e3116e919c26ee13fc1fc3 (patch)
tree623fa377f2c3474b9136b77a90fde3c7dcb7ae18 /app-emulation
parentdev-qt/qt-creator: re-add cvs to live readme (diff)
downloadgentoo-c4e8357dc253dc1de4e3116e919c26ee13fc1fc3.tar.gz
gentoo-c4e8357dc253dc1de4e3116e919c26ee13fc1fc3.tar.bz2
gentoo-c4e8357dc253dc1de4e3116e919c26ee13fc1fc3.zip
app-emulation/vkd3d-proton: update live
wrt static, these are now passed unconditionally for windows platform. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 490163e3132b..573700be0e89 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_SUBMODULES=(
# uses hacks / recent features and easily breaks, keep bundled headers
# (also cross-compiled and -I/usr/include is troublesome)
- subprojects/{SPIRV,Vulkan}-Headers
+ khronos/{SPIRV,Vulkan}-Headers
subprojects/dxil-spirv
subprojects/dxil-spirv/third_party/spirv-headers # skip cross/tools
)
@@ -85,15 +85,13 @@ src_prepare() {
if [[ ${PV} != 9999 ]]; then
rmdir subprojects/{{SPIRV,Vulkan}-Headers,dxil-spirv} || die
mv ../dxil-spirv-${HASH_DXIL} subprojects/dxil-spirv || die
- mv ../SPIRV-Headers-${HASH_SPIRV} subprojects/SPIRV-Headers || die
- mv ../Vulkan-Headers-${HASH_VULKAN} subprojects/Vulkan-Headers || die
+ mv ../SPIRV-Headers-${HASH_SPIRV} khronos/SPIRV-Headers || die
+ mv ../Vulkan-Headers-${HASH_VULKAN} khronos/Vulkan-Headers || die
# dxil and vkd3d's spirv headers currently mismatch and incompatible
rmdir subprojects/dxil-spirv/third_party/spirv-headers || die
mv ../SPIRV-Headers-${HASH_SPIRV_DXIL} \
subprojects/dxil-spirv/third_party/spirv-headers || die
-# ln -s ../../../SPIRV-Headers/include \
-# subprojects/dxil-spirv/third_party/spirv-headers || die
fi
default
@@ -133,10 +131,6 @@ src_configure() {
CHOST_x86=i686-w64-mingw32
CHOST=$(usex x86 ${CHOST_x86} ${CHOST_amd64})
- # preferring meson eclass' cross file over upstream's but, unlike
- # dxvk, we lose static options in the process (from build-win*.txt)
- append-ldflags -static -static-libgcc -static-libstdc++
-
strip-unsupported-flags
fi