summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-03-09 15:18:21 -0700
committerZac Medico <zmedico@gentoo.org>2020-03-09 15:21:44 -0700
commitc979fbf04b85ccf20759a45aec6fbba94afc827a (patch)
tree39abb31ea5939ec155ba75f885ab05e01a2da135 /app-emulation
parentsys-apps/systemd: patch to support gnu11 standard for compilation (diff)
downloadgentoo-c979fbf04b85ccf20759a45aec6fbba94afc827a.tar.gz
gentoo-c979fbf04b85ccf20759a45aec6fbba94afc827a.tar.bz2
gentoo-c979fbf04b85ccf20759a45aec6fbba94afc827a.zip
app-emulation/libpod: fix network-sandbox for go-1.14
Closes: https://bugs.gentoo.org/711964 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libpod/libpod-1.8.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/libpod/libpod-1.8.0.ebuild b/app-emulation/libpod/libpod-1.8.0.ebuild
index 502e3dde382a..27fe79a5b91b 100644
--- a/app-emulation/libpod/libpod-1.8.0.ebuild
+++ b/app-emulation/libpod/libpod-1.8.0.ebuild
@@ -41,11 +41,15 @@ src_prepare() {
# Disable installation of python modules here, since those are
# installed by separate ebuilds.
- sed -e '/^GIT_.*/d' \
- -e 's:GO111MODULE=off:GO111MODULE=on:' \
- -e 's/$(GO) build/$(GO) build -v -work -x/' \
- -e 's/^\(install:.*\) install\.python$/\1/' \
- -i Makefile || die
+ local makefile_sed_args=(
+ -e '/^GIT_.*/d'
+ -e 's/$(GO) build/$(GO) build -v -work -x/'
+ -e 's/^\(install:.*\) install\.python$/\1/'
+ )
+
+ has_version -b '>=dev-lang/go-1.14' || makefile_sed_args+=(-e 's:GO111MODULE=off:GO111MODULE=on:')
+
+ sed "${makefile_sed_args[@]}" -i Makefile || die
sed -e 's|OUTPUT="${CIRRUS_TAG:.*|OUTPUT='v${PV}'|' \
-i hack/get_release_info.sh || die