summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-06 23:41:49 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-06 23:42:43 +0200
commitdb2d9ff98da29912c515a57c4590654471e6c2bc (patch)
tree58d8bd99ab52818e81aeabc596d235d1747545a8 /app-emulation
parentdev-python/safety: Version bump to 1.4.0 (diff)
downloadgentoo-db2d9ff98da29912c515a57c4590654471e6c2bc.tar.gz
gentoo-db2d9ff98da29912c515a57c4590654471e6c2bc.tar.bz2
gentoo-db2d9ff98da29912c515a57c4590654471e6c2bc.zip
app-emulation/kompose: Version bump to 0.7.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-0.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index e02d34f7d5dd..0e3cf3e11d06 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1,2 +1,3 @@
DIST kompose-0.5.0.tar.gz 4960733 SHA256 542828b5b5a231596bc50536322975fab3b49259052de4ad6115b099c01f2627 SHA512 11f3f6a5624fb67ab8be099d220647e8447290311167875efa7ad5a5058bd1401fd5def667ebde3b78eec8404eec81239764d3722e27c60fb55291c4371d36af WHIRLPOOL 50eb0cf5aee7aa2b3868af67d9e3de617ab8cd9ef6af6b1ec48bd772c9e01518e160f2a5b4994748fe474dddad143aac14c85c44a44f1aaf6638c181a6b54d30
DIST kompose-0.6.0.tar.gz 4972911 SHA256 4e42dd2d247ab88382cc29ca9e180cf29e809f8112f533b5a2520c0adb547cdb SHA512 93c4e9864169cbc5f5aacf20db79063bdf97ae1d9ae5942928c36843f4837ddfe7adc4d9fab77ac2470fedfd8653e159f1f0a9a0721f2c2b1edd45dded8bf000 WHIRLPOOL 7360994fc717fe2613117cde7f9da07562b1895abbd49bafe95075a26891b951b484fea95433d0f295c173f4947a2006d3b22cd70c2b36eddba6306526635ee6
+DIST kompose-0.7.0.tar.gz 4980909 SHA256 6b649e91494e57ffd6c6f1d6150072d4c5589d75568172a8f3a0d6cbd7322599 SHA512 a0e8b16221ff25ca5a219646a06dd9254a87c76d5477c5a6c175e782625eb02e41c720278ec409e10f82e8c278ecd941a3d3d49b4220602fec2d3715dbf5e2a7 WHIRLPOOL 460ac6a5c3f25682ec968fef01b72c0b39a8e04cc3d3643f639010e642813a708ea6e91a74dc6d089d90aba6cece6574b83a6b515d2c11bdf9afab34491567f6
diff --git a/app-emulation/kompose/kompose-0.7.0.ebuild b/app-emulation/kompose/kompose-0.7.0.ebuild
new file mode 100644
index 000000000000..3aa81cb86ca6
--- /dev/null
+++ b/app-emulation/kompose/kompose-0.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes-incubator/kompose"
+EGIT_COMMIT="v${PV}"
+COMPOSE_COMMIT="c25b7e8"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes-incubator/kompose"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -ldflags="-X github.com/kubernetes-incubator/kompose/cmd.GITCOMMIT=${COMPOSE_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}