summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-11-18 23:39:56 +0100
committerSebastian Pipping <sping@gentoo.org>2019-11-18 23:47:49 +0100
commite3fa3feb267ade0455c5f36e6faaf0bec54b2a4c (patch)
tree2f9a9bd1f790da9ed4ee62136cbbf12e818a074e /app-emulation
parentx11-wm/herbstluftwm: drop myself as a maintainer (diff)
downloadgentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.tar.gz
gentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.tar.bz2
gentoo-e3fa3feb267ade0455c5f36e6faaf0bec54b2a4c.zip
app-emulation/docker-compose: 1.25.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.16
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.0.ebuild68
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch70
3 files changed, 139 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index 677fb229edc3..088a5454977d 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,2 +1,3 @@
DIST docker-compose-1.24.0.tar.gz 307601 BLAKE2B cb2a6f96e14c04d0279b25c075182d8f09e5a622e4cee2ce74995224e3a8634cc5f22ccc548b7754bbeb11630c1e638386cb1a6df927b3619cb6e7e3595aac6c SHA512 318c6bf9877147de09526b4d49c3fd86012d85626e7a9a15863ca55a60e10fa85b27429605045d0aaa993dddd3bc2e5f23cbb76856276a874e84793b878a3e86
DIST docker-compose-1.24.1.tar.gz 307749 BLAKE2B 7ded0a4b82a7a9beb9de38752f38998ca4ea9421e5ed5630627820ec7e250ad6f03f6788bcbebe8bc0dd4c064d275bb4ca5a6055a95b6a0f72d7ae9038ec7f22 SHA512 9b8632ef263b8dfa678e8b99b46e00441f779716a524280ce25f62fcd2605f400723b7790c466338374c34653946dc2c5d7f09593ddd892fee3409c2a2fd1a5f
+DIST docker-compose-1.25.0.tar.gz 320048 BLAKE2B a0615c9d81f897f551d664799e2a7cd4d72c3e0b70ceb0ff9bfb533a81799d2d524824ead27bff2391c5e98fc34430fb2ba724bba663ece66417ac72181241f0 SHA512 38be153a8ba1bf1a4a5c63dc794db3344c93c0819fba0c38feb791067e0aa72142205e4255b5fd31bf2f8159dfa04cde09fdcdabe0511bc0e2865974dff5433d
diff --git a/app-emulation/docker-compose/docker-compose-1.25.0.ebuild b/app-emulation/docker-compose/docker-compose-1.25.0.ebuild
new file mode 100644
index 000000000000..bc3f9067249c
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.25.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
+
+DEPEND="${RDEPEND}
+ test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
+ <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
+
+S="${WORKDIR}/compose-${PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.25.0-setup-py.patch
+)
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch
new file mode 100644
index 000000000000..029dc54bb8f7
--- /dev/null
+++ b/app-emulation/docker-compose/files/docker-compose-1.25.0-setup-py.patch
@@ -0,0 +1,70 @@
+From 8f2924d4146ddb1131e98efbee13a68b5445b7f8 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 18 Nov 2019 23:34:51 +0100
+Subject: [PATCH] setup.py: Drop generic upper version boundaries
+
+---
+ setup.py | 36 ++++++++++++++++++------------------
+ 1 file changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 23ae08a..97a8fbe 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,35 +30,35 @@ def find_version(*file_paths):
+
+
+ install_requires = [
+- 'cached-property >= 1.2.0, < 2',
+- 'docopt >= 0.6.1, < 1',
+- 'PyYAML >= 3.10, < 5',
+- 'requests >= 2.20.0, < 3',
+- 'texttable >= 0.9.0, < 2',
+- 'websocket-client >= 0.32.0, < 1',
+- 'docker[ssh] >= 3.7.0, < 5',
+- 'dockerpty >= 0.4.1, < 1',
+- 'six >= 1.3.0, < 2',
+- 'jsonschema >= 2.5.1, < 4',
++ 'cached-property >= 1.2.0',
++ 'docopt >= 0.6.1',
++ 'PyYAML >= 3.10',
++ 'requests >= 2.20.0',
++ 'texttable >= 0.9.0',
++ 'websocket-client >= 0.32.0',
++ 'docker[ssh] >= 3.7.0',
++ 'dockerpty >= 0.4.1',
++ 'six >= 1.3.0',
++ 'jsonschema >= 2.5.1',
+ ]
+
+
+ tests_require = [
+- 'pytest < 6',
++ 'pytest',
+ ]
+
+
+ if sys.version_info[:2] < (3, 4):
+- tests_require.append('mock >= 1.0.1, < 4')
++ tests_require.append('mock >= 1.0.1')
+
+ extras_require = {
+- ':python_version < "3.2"': ['subprocess32 >= 3.5.4, < 4'],
+- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
+- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
++ ':python_version < "3.2"': ['subprocess32 >= 3.5.4'],
++ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
++ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
+ ':python_version < "3.3"': ['backports.shutil_get_terminal_size == 1.0.0',
+- 'ipaddress >= 1.0.16, < 2'],
+- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
+- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
++ 'ipaddress >= 1.0.16'],
++ ':sys_platform == "win32"': ['colorama >= 0.4'],
++ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
+ }
+
+
+--
+2.23.0
+