summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-22 11:11:40 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-27 12:02:08 +0200
commitedf1f6112c95190d1cb9eeae07e9954970b3ab4c (patch)
treef76a785b440fa416df42b6cf2b3a257e86b39edf /app-emulation
parentapp-shells/bash-completion: Skip tests relying on networking (diff)
downloadgentoo-edf1f6112c95190d1cb9eeae07e9954970b3ab4c.tar.gz
gentoo-edf1f6112c95190d1cb9eeae07e9954970b3ab4c.tar.bz2
gentoo-edf1f6112c95190d1cb9eeae07e9954970b3ab4c.zip
app-emulation/ganeti: Add missing ||die
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ganeti-2.15.2-r10.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-emulation/ganeti/ganeti-2.15.2-r10.ebuild b/app-emulation/ganeti/ganeti-2.15.2-r10.ebuild
index 4427da82567e..40729b5f912a 100644
--- a/app-emulation/ganeti/ganeti-2.15.2-r10.ebuild
+++ b/app-emulation/ganeti/ganeti-2.15.2-r10.ebuild
@@ -259,28 +259,30 @@ src_prepare() {
# 24618882737fd7c189adf99f4acc767d48f572c3
sed -i \
-e '/QuickCheck/s,< 2.8,< 2.8.3,g' \
- cabal/ganeti.template.cabal
+ cabal/ganeti.template.cabal || die
# Neuter -Werror
sed -i \
-e '/^if DEVELOPER_MODE/,/^endif/s/-Werror//' \
- Makefile.am
+ Makefile.am || die
# not sure why these tests are failing
# should remove this on next version bump if possible
for testfile in test/py/import-export_unittest.bash; do
- printf '#!/bin/bash\ntrue\n' > "${testfile}"
+ printf '#!/bin/bash\ntrue\n' > "${testfile}" || die
done
# take the sledgehammer approach to bug #526270
- grep -lr '/bin/sh' "${S}" | xargs -r -- sed -i 's:/bin/sh:/bin/bash:g'
+ grep -lr '/bin/sh' "${S}" | xargs -r -- sed -i 's:/bin/sh:/bin/bash:g' || die
sed "s:%LIBDIR%:$(get_libdir):g" "${FILESDIR}/ganeti.initd-r4" \
- > "${T}/ganeti.initd"
+ > "${T}/ganeti.initd" || die
eapply_user
- [[ ${PV} =~ [9]{4,} ]] && ./autogen.sh
- rm autotools/missing
+ if [[ ${PV} =~ [9]{4,} ]]; then
+ ./autogen.sh || die
+ fi
+ rm autotools/missing || die
eautoreconf
}
@@ -329,9 +331,9 @@ src_install() {
fi
# ganeti installs it's own docs in a generic location
- rm -rf "${D}"/{usr/share/doc/${PN},run}
+ rm -rf "${D}"/{usr/share/doc/${PN},run} || die
- sed -i "s:/usr/$(get_libdir)/${PN}/tools/burnin:burnin:" doc/examples/bash_completion
+ sed -i "s:/usr/$(get_libdir)/${PN}/tools/burnin:burnin:" doc/examples/bash_completion || die
newbashcomp doc/examples/bash_completion gnt-instance
bashcomp_alias gnt-instance burnin ganeti-{cleaner,confd} \
h{space,check,scan,info,ail,arep,roller,squeeze,bal} \