summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-11-07 15:51:17 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-11-07 15:51:26 +0100
commitf038f1c0cb51c1435dc828eb7d63e0a2389d3aa3 (patch)
tree4681d69de4f80689706f6f3e52e1b0c0536ee0d5 /app-emulation
parentapp-text/paperwork: install l10n and data files (diff)
downloadgentoo-f038f1c0cb51c1435dc828eb7d63e0a2389d3aa3.tar.gz
gentoo-f038f1c0cb51c1435dc828eb7d63e0a2389d3aa3.tar.bz2
gentoo-f038f1c0cb51c1435dc828eb7d63e0a2389d3aa3.zip
app-emulation/plus42: add 1.0.21
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/plus42-1.0.21.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index 8d6a4b257cce..0b6b64116938 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1,2 +1,3 @@
DIST plus42-upstream-1.0.17.tgz 7592298 BLAKE2B 262b985bb9f42ff98a218676ce9d831494cd4cb72db8c6557e3ebb2b5e43f7545c1f7c20a3c7297921a3fc77dea366b1cf4c7745cc9d473e18c395fbe43c05ea SHA512 79e1310f2fb34b34b827c84ca6749b7af6a800a97fb9ada4bba19cc477f3ff7077fe51b82c3e8845049f65d9abd83dc4f8bac9ea522f8a8ca46bb5a43b786623
DIST plus42-upstream-1.0.20.tgz 7595277 BLAKE2B 17ab2955a7408436756709362026590c4be40ad1049106c17a596c5e370343457e0f26d01099c89c40f1f57d2c90b066f4e6c4a4bd6e39263d6bd1301e39f814 SHA512 a91853b61cb72f61d2cc3cbf1e700c64d9ffabde87037017230513fc908bd35a2310e460e73e0d9d3eb459db41a082527ad32ff4714737376d735434bbb140bd
+DIST plus42-upstream-1.0.21.tgz 7596740 BLAKE2B 2710ec70682ea8a68ff07388c210bd253f5a91736caa017efed036b0cba41a9895721287246982477adaf4288d79d195cf6543b79d5e0905b62acc91becd4da8 SHA512 55b42e006ce003c9e619fa10ec7e28319f82444bce0f811f9ebdd16c0ceeded9e978a3f7c0b134bdc17c39a55f1071b8245d099d1c7d9a7b81bfe850d30bd962
diff --git a/app-emulation/plus42/plus42-1.0.21.ebuild b/app-emulation/plus42/plus42-1.0.21.ebuild
new file mode 100644
index 000000000000..89d41071d3b2
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.0.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="app-accessibility/at-spi2-core
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.12-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}