summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-05-31 11:33:21 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-05-31 11:33:21 +0200
commitf251eb2e6990882190d5bf38b7b2ade82be12128 (patch)
tree7b0f179e45fb0dcb7ffaa6b5388bfbd7b29c4aaf /app-emulation
parentsys-apps/portage: fix --nodeps with --keep-going (bug 656942) (diff)
downloadgentoo-f251eb2e6990882190d5bf38b7b2ade82be12128.tar.gz
gentoo-f251eb2e6990882190d5bf38b7b2ade82be12128.tar.bz2
gentoo-f251eb2e6990882190d5bf38b7b2ade82be12128.zip
app-emulation/img: Initial version
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.3.6.ebuild32
-rw-r--r--app-emulation/img/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
new file mode 100644
index 000000000000..4b5ebf49c7dc
--- /dev/null
+++ b/app-emulation/img/Manifest
@@ -0,0 +1 @@
+DIST img-0.3.6.tar.gz 6043716 BLAKE2B 982a6f470f4b79cd4cc2b06be4060f516786f700872510948a25d5ad313cccf402b0fe26c053f7505b66c170221274568ce44632729c16e1ade680b5dc007b0d SHA512 911cf6a761741a04553d5e526399973c0e943cfda5eead7f94196969fed4f586134358b1e6f023c6cf07e755de802e498991eb320bd50af32649749622a26969
diff --git a/app-emulation/img/img-0.3.6.ebuild b/app-emulation/img/img-0.3.6.ebuild
new file mode 100644
index 000000000000..9ebadf2113aa
--- /dev/null
+++ b/app-emulation/img/img-0.3.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e4a43d044778e3df56e0de3c6ca00706fcca8b50"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags ${TAGS} -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
new file mode 100644
index 000000000000..06bfaa067c93
--- /dev/null
+++ b/app-emulation/img/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">genuinetools/img</remote-id>
+ </upstream>
+</pkgmetadata>