summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-05 15:16:05 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-05 15:16:05 +0200
commitfa01bf1701580d82ad70afef7f4f05fba5c6b633 (patch)
tree3fd16ac3f32d7629fcddffb9f496aac41f2257ad /app-emulation
parentgnustep-apps/pikopixel: revision bump to get beta9c version (diff)
downloadgentoo-fa01bf1701580d82ad70afef7f4f05fba5c6b633.tar.gz
gentoo-fa01bf1701580d82ad70afef7f4f05fba5c6b633.tar.bz2
gentoo-fa01bf1701580d82ad70afef7f4f05fba5c6b633.zip
app-emulation/kompose: Version bump to 1.14.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kompose/Manifest1
-rw-r--r--app-emulation/kompose/kompose-1.14.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/kompose/Manifest b/app-emulation/kompose/Manifest
index 60a3d2c3ce78..265792572209 100644
--- a/app-emulation/kompose/Manifest
+++ b/app-emulation/kompose/Manifest
@@ -1,2 +1,3 @@
DIST kompose-1.12.0.tar.gz 5234150 BLAKE2B 0b046cc2fb9420a69bb8a2d82a7c4f8a62db74acfaa9cdc5dc16b3710cda7c03fb43651bdd1e43281502f4aa181b50168120375a7f0e298a1ba018ddb94cd43a SHA512 5467b8fa54fe9368f1f1627c04e4edab597822b7b2c3c101510379cceac8ca92e24540b81b82e947244b1b4056e2b1a5806220b38bbe5db5965c3f7aeff908ef
DIST kompose-1.13.0.tar.gz 5238799 BLAKE2B 8f51d9c4b162104636578b5b6b044060997d7c8fbd8a58fdf42d8db1e5fbce51cbfd2e010e84e80707462edc29603da3a6ac729f95873f2c84b7a43baeac8284 SHA512 6ec870f03762bde138e2c22e9b8a85a1e974897f3857f096e1fcd56bd402d1f3379936752b075ee57497e5d4f1c7c7d0c82b09d6c4e90860cc04aee434123419
+DIST kompose-1.14.0.tar.gz 5238716 BLAKE2B 27c054b58d2804fcb37627652d2d48ff377504203f9319c4321fcba08e9c8dd9c41f307ff599de3b65ae9a177370322d63314b70e5cb80edf1ce071eeaf15e24 SHA512 f356f2f38c99f0ca9d8f58a4dfa171ba0c41b3127b66ab887484c3bbc76b66470fbe8f52ca3eeba700b57a86e0ff264066ee92645f71a93bfe77077655f81e97
diff --git a/app-emulation/kompose/kompose-1.14.0.ebuild b/app-emulation/kompose/kompose-1.14.0.ebuild
new file mode 100644
index 000000000000..e0d3bde8bce1
--- /dev/null
+++ b/app-emulation/kompose/kompose-1.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/kubernetes/kompose"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="fa706f2f1c715889cbfffdf7e4a65da4c58584cd"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Tool to move from docker-compose to Kubernetes"
+HOMEPAGE="https://github.com/kubernetes/kompose https://kompose.io"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened"
+
+RESTRICT="test"
+
+src_compile() {
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
+ GOPATH="${S}" go build -v -ldflags="-X github.com/kubernetes/kompose/cmd.GITCOMMIT=${GIT_COMMIT}" -o bin/kompose src/${EGO_PN}/main.go || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/{docs,{README,RELEASE,ROADMAP,CHANGELOG,CONTRIBUTING}.md}
+}