summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-19 03:56:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-19 04:15:13 -0400
commitfa6e99d52607a09465127b2f60b5962b3a06bedc (patch)
tree18aa7820373dbae751376860fad7f0e492b6114f /app-emulation
parentdev-python/pymdown-extensions: Stabilize 10.0.1 ALLARCHES, #906714 (diff)
downloadgentoo-fa6e99d52607a09465127b2f60b5962b3a06bedc.tar.gz
gentoo-fa6e99d52607a09465127b2f60b5962b3a06bedc.tar.bz2
gentoo-fa6e99d52607a09465127b2f60b5962b3a06bedc.zip
app-emulation/wine-mono: add 8.0.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-mono/Manifest2
-rw-r--r--app-emulation/wine-mono/wine-mono-8.0.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/Manifest b/app-emulation/wine-mono/Manifest
index 908201b7439d..f600056c751f 100644
--- a/app-emulation/wine-mono/Manifest
+++ b/app-emulation/wine-mono/Manifest
@@ -4,3 +4,5 @@ DIST wine-mono-7.4.0-x86.msi 87334912 BLAKE2B c0b778f9db59d1a2917631f1d6ca1a1798
DIST wine-mono-7.4.0-x86.tar.xz 45404344 BLAKE2B 3a74106b9b3f21a88c2435f7988d66a54e08beea931a0ce0df6431c21add4ee2685bf9c9cb2404ee1a685736d61b1aee3cdd507130e5c5dddba7e506a2ff18bb SHA512 108cb5d969e84deeda3d2b11dba7cd73853fc3b088ecf2bcdb9bc5c5bbaaff03e72cd4f485d1935eda43cdd95b927886441be1d2204edeaee1ff1fea75735d22
DIST wine-mono-7.4.1-x86.msi 87339008 BLAKE2B 571469f21f4b2f4483172ef88cd973f94dd09eed3b9312775339711901fc5cd753944802a10e35c22f68b8685ae10f782e005f6ae9fcf7afc7b4da039a732b34 SHA512 ac2b398ce4c58b35da05d6d002f04cbdf7c615a9058f3db8e00f6c10166be84d90fc09ffa7e44f171e97bd91b741855f1547036d2eca2a688a92e3ed4297762a
DIST wine-mono-7.4.1-x86.tar.xz 44433444 BLAKE2B 28adbcca630698e74e455fbe37b8cd60c3d836c503db6a2df20e4db3e12f549a5d1fae6a4c0ccd6068e2667f700fbfe09858b95f156ad8d660ef3804773179a0 SHA512 2d0b231ee6e34d23f1e2ae0d7995dd31caab352f30816302743f884f5da56a071e931dabb53f813dd5389c82bdab70057b1d5c6430f1f88ace93789e41962cb6
+DIST wine-mono-8.0.0-x86.msi 84587008 BLAKE2B ad2e94b89ef40497009b3a4c1df368482ad48f9061091ecf83298be54836aed7169f10c50e9df62e5aac7843afa087daf4fcc75a4b5c50153bd6f64e70396494 SHA512 579bd4914784b0e23120f9750b9b92d9416f1a66e6bb5ff7692ec88368f10d034fdf1c817032dadb8b4dd9758e34aff6e43f5085792239ffc28585f95e167c21
+DIST wine-mono-8.0.0-x86.tar.xz 42360588 BLAKE2B ef3ffceb788bb5683de105c20741be8d2ac63622edfa22cd60bf6fb5833ecab19b51ba5fe1ff6cd1a30425fd26ff861e4ad2d5eaf97d38251f66e88e54ab04ea SHA512 7ffa8a87c9e23d84fee789da83f29480d91b79915d3acaa15803699d8ee1575097e24c38fb0e23b22fc5b67f64287fa3f7979b1a077c08ed2f5b69643dcacd4f
diff --git a/app-emulation/wine-mono/wine-mono-8.0.0.ebuild b/app-emulation/wine-mono/wine-mono-8.0.0.ebuild
new file mode 100644
index 000000000000..96896ce732cf
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-8.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://wiki.winehq.org/Mono"
+SRC_URI="
+ shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.tar.xz )
+ !shared? ( https://github.com/madewokherd/wine-mono/releases/download/${P}/${P}-x86.msi )"
+S="${WORKDIR}"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+shared"
+
+src_install() {
+ insinto /usr/share/wine/mono
+
+ if use shared; then
+ doins -r ${P}
+ else
+ doins "${DISTDIR}"/${P}-x86.msi
+ fi
+}