summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-05-16 11:26:14 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-05-16 11:28:58 +0200
commitffe025f0307e48c94337b9bcff57a45abe30d816 (patch)
tree34e85975f90e527acf042f2ccc969a7587fcbaf5 /app-emulation
parentmedia-video/ffdiaporama: Cleanup metadata (diff)
downloadgentoo-ffe025f0307e48c94337b9bcff57a45abe30d816.tar.gz
gentoo-ffe025f0307e48c94337b9bcff57a45abe30d816.tar.bz2
gentoo-ffe025f0307e48c94337b9bcff57a45abe30d816.zip
app-emulation/xen-tools: apply patch fixing implicit function declarations in config
Closes: https://bugs.gentoo.org/904449 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/files/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch39
-rw-r--r--app-emulation/xen-tools/xen-tools-4.15.5_pre1-r1.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.15.5_pre1.ebuild)4
-rw-r--r--app-emulation/xen-tools/xen-tools-4.16.4-r1.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.16.4.ebuild)4
-rw-r--r--app-emulation/xen-tools/xen-tools-4.17.1-r1.ebuild (renamed from app-emulation/xen-tools/xen-tools-4.17.1.ebuild)4
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/xen-tools/files/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch b/app-emulation/xen-tools/files/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch
new file mode 100644
index 000000000000..02d1f0ff8b1f
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch
@@ -0,0 +1,39 @@
+From 873d4759aa7b0581bf34e8a7ebfcbeca789ed6e1 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Tue, 16 May 2023 09:56:48 +0200
+Subject: [PATCH] m4/ptyfuncs.m4 tools/configure: add linux headers for pty
+ functions
+
+To avoid implicit function declarations, which will cause an error on
+modern compilers. See https://wiki.gentoo.org/wiki/Modern_C_porting
+
+Downstream Gentoo bug: https://bugs.gentoo.org/904449
+
+Signed-off-by: Florian Schmaus <flo@geekplace.eu>
+--- a/m4/ptyfuncs.m4
++++ b/m4/ptyfuncs.m4
+@@ -19,6 +19,9 @@ AC_DEFUN([AX_CHECK_PTYFUNCS], [
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #ifdef INCLUDE_LIBUTIL_H
+ #include INCLUDE_LIBUTIL_H
++#else
++#include <pty.h>
++#include <utmp.h>
+ #endif
+ int main(void) {
+ openpty(0,0,0,0,0);
+--- a/tools/configure
++++ b/tools/configure
+@@ -9002,6 +9002,9 @@ See \`config.log' for more details" "$LINENO" 5; }
+
+ #ifdef INCLUDE_LIBUTIL_H
+ #include INCLUDE_LIBUTIL_H
++#else
++#include <pty.h>
++#include <utmp.h>
+ #endif
+ int main(void) {
+ openpty(0,0,0,0,0);
+--
+2.39.3
+
diff --git a/app-emulation/xen-tools/xen-tools-4.15.5_pre1.ebuild b/app-emulation/xen-tools/xen-tools-4.15.5_pre1-r1.ebuild
index 75003ae0412f..b4d296686754 100644
--- a/app-emulation/xen-tools/xen-tools-4.15.5_pre1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.15.5_pre1-r1.ebuild
@@ -209,6 +209,10 @@ QA_PREBUILT="
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch"
+)
+
pkg_setup() {
python_setup
export "CONFIG_LOMOUNT=y"
diff --git a/app-emulation/xen-tools/xen-tools-4.16.4.ebuild b/app-emulation/xen-tools/xen-tools-4.16.4-r1.ebuild
index 578e95053175..fbeaed9743e8 100644
--- a/app-emulation/xen-tools/xen-tools-4.16.4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.16.4-r1.ebuild
@@ -208,6 +208,10 @@ QA_PREBUILT="
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch"
+)
+
pkg_setup() {
python_setup
export "CONFIG_LOMOUNT=y"
diff --git a/app-emulation/xen-tools/xen-tools-4.17.1.ebuild b/app-emulation/xen-tools/xen-tools-4.17.1-r1.ebuild
index c1abdbc8c7f5..d324baad0b3a 100644
--- a/app-emulation/xen-tools/xen-tools-4.17.1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.17.1-r1.ebuild
@@ -208,6 +208,10 @@ QA_PREBUILT="
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/xen-tools-m4-ptyfuncs.m4-tools-configure-add-linux-headers-for.patch"
+)
+
pkg_setup() {
python_setup
export "CONFIG_LOMOUNT=y"