summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-01-01 16:20:06 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-01-01 22:49:14 +0000
commit47b7e0290735f8af61a8df3323ff873d4968ce85 (patch)
tree5e92db778de4bc7445c5de44eb5692bf48824366 /app-eselect/eselect-java/eselect-java-0.2.0.ebuild
parentjava-vm-2.eclass: Only call nsplugin functions if necessary (diff)
downloadgentoo-47b7e0290735f8af61a8df3323ff873d4968ce85.tar.gz
gentoo-47b7e0290735f8af61a8df3323ff873d4968ce85.tar.bz2
gentoo-47b7e0290735f8af61a8df3323ff873d4968ce85.zip
app-eselect/eselect-java: Version bump
This version removes the java-nsplugin module. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-eselect/eselect-java/eselect-java-0.2.0.ebuild')
-rw-r--r--app-eselect/eselect-java/eselect-java-0.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/eselect-java-0.2.0.ebuild b/app-eselect/eselect-java/eselect-java-0.2.0.ebuild
new file mode 100644
index 000000000000..a86b5345d814
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://www.gentoo.org/proj/en/java/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ !app-eselect/eselect-ecj
+ !app-eselect/eselect-maven
+ !<dev-java/java-config-2.2
+ app-admin/eselect"
+
+src_prepare() {
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ "${REMOVED}" = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}