summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-06-24 12:34:16 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-24 12:39:19 +0200
commitb81c6cda810dcb3e322a554b9cde88cd27c47248 (patch)
tree71294ed471e975c463f9327a1a6a9dddb1ccd8d2 /app-eselect/eselect-java
parentdev-python/keyring: Remove old (diff)
downloadgentoo-b81c6cda810dcb3e322a554b9cde88cd27c47248.tar.gz
gentoo-b81c6cda810dcb3e322a554b9cde88cd27c47248.tar.bz2
gentoo-b81c6cda810dcb3e322a554b9cde88cd27c47248.zip
app-eselect/eselect-java: add 0.5.0
Bug: https://bugs.gentoo.org/853928 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-java')
-rw-r--r--app-eselect/eselect-java/Manifest1
-rw-r--r--app-eselect/eselect-java/eselect-java-0.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/Manifest b/app-eselect/eselect-java/Manifest
index fe408730aa17..46bbf129f9d5 100644
--- a/app-eselect/eselect-java/Manifest
+++ b/app-eselect/eselect-java/Manifest
@@ -1 +1,2 @@
DIST eselect-java-0.4.3.tar.bz2 13799 BLAKE2B 353035ef1c0b3e1cd79021c9198bedf29fdcb3f13fdfb2e5a8384796f2a48236d671f07d7657409273dd1f52e37272d91383d2a14d64ed0cedb686a8e277b009 SHA512 40b10768f00f03c49e1b60aab615658ac1d986444aaf487ca74f7c14edb5dce62d85fc3ce049e857d0ec2eaea496afa17c45de59e7179331f112eb51cbe451e5
+DIST eselect-java-0.5.0.tar.bz2 14271 BLAKE2B dc285ad17b62043cc5085a586547a06a12c09f5a80f25dc423db9cb806baaa669a55106f605973fcae7103e35ec673ae2e3a6119730b1789e816a09079deabc8 SHA512 89724b96125911f0abc0363e0b2c9df75d0d52df1a5e16e80efa20a8de39b1bc0d411d297581b3440c944f498688e5dcffe5432f5e46836115d2eb620f31c03a
diff --git a/app-eselect/eselect-java/eselect-java-0.5.0.ebuild b/app-eselect/eselect-java/eselect-java-0.5.0.ebuild
new file mode 100644
index 000000000000..ef497b375a18
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"/usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"/etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ ${REMOVED} = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}