summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-11-24 15:11:36 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-11-24 15:12:00 -0500
commita0709457d61898989510adfa26c4cb615f18165b (patch)
tree7f132dc2e3c7d244d696bbb1e97d70cad8513ba7 /app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild
parentmedia-video/cheese: fix subslot (diff)
downloadgentoo-a0709457d61898989510adfa26c4cb615f18165b.tar.gz
gentoo-a0709457d61898989510adfa26c4cb615f18165b.tar.bz2
gentoo-a0709457d61898989510adfa26c4cb615f18165b.zip
app-eselect/eselect-php: new revision to test config before FPM start/reload.
Now that we have a configtest() command for the php-fpm daemon, we should run it before attempting to reload the daemon. This prevents the (working) daemon from crashing if the new config has a typo in it. Performing the same check before start() avoids a five-second wait if there is an error in the config. Gentoo-Bug: 487642 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild b/app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild
new file mode 100644
index 000000000000..6937b4ad0081
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.7.1-r7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://www.gentoo.org"
+SRC_URI="https://dev.gentoo.org/~olemarkus/eselect-php/eselect-php-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php5.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+S="${WORKDIR}"
+
+want_apache
+
+src_install() {
+ insinto /usr/share/eselect/modules/
+ newins "eselect-php-${PV}" php.eselect
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ newins "${FILESDIR}/70_mod_php5.conf-apache2-r1" \
+ "70_mod_php5.conf"
+ fi
+
+ if use fpm ; then
+ newinitd "${FILESDIR}/php-fpm.init-r4" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}