summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-10-25 11:18:41 -0400
committerBrian Evans <grknight@gentoo.org>2021-10-25 11:19:43 -0400
commite785f0feadc654eb5c1188c3853ca8071fc4277c (patch)
treeee5213f61c98bb7e4fdb07ece892691b39cc14a8 /app-eselect/eselect-php/eselect-php-0.9.8.ebuild
parentdev-db/postgis: Add 3.2.0_beta1 (diff)
downloadgentoo-e785f0feadc654eb5c1188c3853ca8071fc4277c.tar.gz
gentoo-e785f0feadc654eb5c1188c3853ca8071fc4277c.tar.bz2
gentoo-e785f0feadc654eb5c1188c3853ca8071fc4277c.zip
app-eselect/eselect-php: Version bump for 0.9.8
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-0.9.8.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.9.8.ebuild b/app-eselect/eselect-php/eselect-php-0.9.8.ebuild
new file mode 100644
index 000000000000..a316d2866307
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+TMPFILES_OPTIONAL="yes"
+inherit tmpfiles
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~grknight/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
+
+src_configure() {
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ #
+ # The libdir is passed explicitly in case the /usr/lib symlink
+ # is not present (bug 624528).
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-piddir="${EPREFIX}/run" \
+ $(use_enable apache2) \
+ $(use_enable fpm)
+}
+
+pkg_postinst() {
+ use fpm && tmpfiles_process php-fpm.conf
+}