summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-07-19 13:21:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-07-19 13:22:22 -0700
commitf0ff428c4889509082676f5d6f0cc90886c646a8 (patch)
tree238c4ff7a1aa9e83c00c99aacc992b068513fe06 /app-eselect/eselect-python/eselect-python-20200719.ebuild
parentdev-python/pythondialog: Drop 3.3.0 (diff)
downloadgentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.tar.gz
gentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.tar.bz2
gentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.zip
app-eselect/eselect-python-20200719: Version bump
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-python/eselect-python-20200719.ebuild')
-rw-r--r--app-eselect/eselect-python/eselect-python-20200719.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/eselect-python-20200719.ebuild b/app-eselect/eselect-python/eselect-python-20200719.ebuild
new file mode 100644
index 000000000000..745d4e05cb20
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20200719.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~chutzpah/dist/misc/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# python-exec-2.4.2 for working -l option
+RDEPEND="
+ >=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}