summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-29 14:52:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-29 14:52:07 +0200
commita824663636768c74d61b211d247ef203964768f3 (patch)
treeabc3ccf9e9d05f1315dddbb860de8a504b8bc984 /app-eselect/eselect-repository/eselect-repository-7.ebuild
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.0.90 (GTK+3 port) (diff)
downloadgentoo-a824663636768c74d61b211d247ef203964768f3.tar.gz
gentoo-a824663636768c74d61b211d247ef203964768f3.tar.bz2
gentoo-a824663636768c74d61b211d247ef203964768f3.zip
app-eselect/eselect-repository: Bump to v7
Closes: https://bugs.gentoo.org/686926 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-repository/eselect-repository-7.ebuild')
-rw-r--r--app-eselect/eselect-repository/eselect-repository-7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/eselect-repository-7.ebuild b/app-eselect/eselect-repository/eselect-repository-7.ebuild
new file mode 100644
index 000000000000..1e3790748b61
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ dev-python/lxml[${PYTHON_USEDEP}]
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ keepdir /var/db/repos
+ einstalldocs
+}