summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-03-09 18:51:14 +0600
committerJoonas Niilola <juippis@gentoo.org>2023-03-09 15:03:40 +0200
commit44449238d9f6f5665b352013369612931217074f (patch)
treef5cbcaabe8e9ef70bedb4038da7b58ae7b07d7f5 /app-eselect/eselect-zig/eselect-zig-1-r1.ebuild
parentdev-python/pydata-sphinx-theme: Bump to 0.13.1 (diff)
downloadgentoo-44449238d9f6f5665b352013369612931217074f.tar.gz
gentoo-44449238d9f6f5665b352013369612931217074f.tar.bz2
gentoo-44449238d9f6f5665b352013369612931217074f.zip
app-eselect/eselect-zig: fix remove_symlink -> remove_symlinks
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/30016 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-zig/eselect-zig-1-r1.ebuild')
-rw-r--r--app-eselect/eselect-zig/eselect-zig-1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-zig/eselect-zig-1-r1.ebuild b/app-eselect/eselect-zig/eselect-zig-1-r1.ebuild
new file mode 100644
index 000000000000..6986fff09954
--- /dev/null
+++ b/app-eselect/eselect-zig/eselect-zig-1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manages Zig versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ app-admin/eselect
+ !dev-lang/zig:0
+ !dev-lang/zig-bin:0
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/eselect/modules/
+ newins "${FILESDIR}"/zig.eselect-${PVR} zig.eselect
+}