summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 21:25:54 +0000
committerSam James <sam@gentoo.org>2022-03-20 21:25:59 +0000
commit1cd3804bdc11dbad287903ad7a13e63d9d8c81e0 (patch)
treea244ad29874abd4de0c3675853dbf027c3d79c71 /app-eselect
parentsys-libs/glibc: add safety check for /usr/lib/include (diff)
downloadgentoo-1cd3804bdc11dbad287903ad7a13e63d9d8c81e0.tar.gz
gentoo-1cd3804bdc11dbad287903ad7a13e63d9d8c81e0.tar.bz2
gentoo-1cd3804bdc11dbad287903ad7a13e63d9d8c81e0.zip
app-eselect/eselect-iptables: add 20220320
Fixes installing ip6tables symlinks when using newer iptables w/o USE=ipv6 (it's always on now). Closes: https://bugs.gentoo.org/835613 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-iptables/Manifest1
-rw-r--r--app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-eselect/eselect-iptables/Manifest b/app-eselect/eselect-iptables/Manifest
index 0a2ac807b2da..bc40c152da5d 100644
--- a/app-eselect/eselect-iptables/Manifest
+++ b/app-eselect/eselect-iptables/Manifest
@@ -1 +1,2 @@
DIST eselect-iptables-20211203.tar.xz 2144 BLAKE2B 9a53784a0831e7d2c150a974faba6c9dc124b0eafdd22cd8a56d342f77d9d4741fb0ff289e429351b8cff2e7576d00ba7e66d36c73ebe7c43c9d42cf56c13292 SHA512 5a670d72f20722df12bae7baa9ad68175e9678610657e24c4182ef83f30cc356b7af2f3bd8ea22e16aa83ba34cf5c407761c6dc2b937a4488b2da47dcb9eca97
+DIST eselect-iptables-20220320.tar.xz 2152 BLAKE2B 82813bf7814b91f1cf6da35c5c893e8ca28a8f5b5885e234c12853b5dc3afd73b3e0512e9d3d379e81b466706eabef8774d1b5738dd12582bbf1e344294a80f8 SHA512 7783d94d3bc463e0e8e084368c3906358efd03c9e47898686943d4900babd84e038991338f78459fca410f618dd5a62020e3d2af5ae45554f323a70a9b284135
diff --git a/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild b/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
new file mode 100644
index 000000000000..9c41e81fefd2
--- /dev/null
+++ b/app-eselect/eselect-iptables/eselect-iptables-20220320.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the {,/usr}/sbin/iptables symlink"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-iptables.git/"
+SRC_URI="https://dev.gentoo.org/~chutzpah/dist/iptables/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins iptables.eselect
+
+ local symlink
+ for symlink in {eb,arp}tables; do
+ dosym iptables.eselect /usr/share/eselect/modules/${symlink}.eselect
+ done
+}