summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-02-25 19:54:20 +0100
committerMichał Górny <mgorny@gentoo.org>2016-02-25 21:29:06 +0100
commit6dde78ab6c01225a54125e2ec4e97c17df36d220 (patch)
tree7f615d55dc3897d9a37ec6a8687f46e3926b1cb7 /app-eselect
parentdev-python/jpype: Switch to java-pkg-2. (diff)
downloadgentoo-6dde78ab6c01225a54125e2ec4e97c17df36d220.tar.gz
gentoo-6dde78ab6c01225a54125e2ec4e97c17df36d220.tar.bz2
gentoo-6dde78ab6c01225a54125e2ec4e97c17df36d220.zip
app-eselect/eselect-python: Bump to 20160222
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-python/Manifest1
-rw-r--r--app-eselect/eselect-python/eselect-python-20160222.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index d2da3df1e300..84bb0fe99636 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -4,3 +4,4 @@ DIST eselect-python-20140115.tar.bz2 71910 SHA256 5898ee19015ae905168e8b7aa76552
DIST eselect-python-20140125.tar.bz2 72102 SHA256 ee7b470f7facc42285bab7f4b947280741515a85c9067339511c219248f8fdfb SHA512 94d4eb5a1af365c6f56a6fc2b75298018267cd4f6004f30b2e4d0c4744d3e82b33f6c82e6f0ea0f15132d5157c3ace99fa167bbf3ebada46edd2e005ca96eb51 WHIRLPOOL 70d5f9af2929507d26e56080ce934066d2de5f16030dfd63b016215465ad5fc89eb952d64cc545c7058d146108e26925741d2c8fbaba08abba1a5cae7b0c23b6
DIST eselect-python-20151117.tar.bz2 62793 SHA256 6f2912ae4d4fc12949ae0c9bb8b93b3a3a8c372336c2138c758f042f91484561 SHA512 3e680f8c851251176d6bb916d003e421e4b414aa9cc59e20cb15d454a3251cdf1e587828e9b2a5db461641f277e3b764ca172f4466fe3f6ef9679a9a05a71732 WHIRLPOOL a2e4ca676ead692b08a6194fb4bf5dabdd383ad158f45a17cb21c59022af139b0646fe39b0f4c9b540c80c4c2a04362c75f90e3c7f1506056b7b0f01e5e51474
DIST eselect-python-20160207.tar.bz2 57454 SHA256 1da389c71b2b133ce56daae199334e920766d78e9e424d66cd76753a99b19a82 SHA512 ff83fb43df85ef0989ab9f557800e9ef97cd5b4e01316bc4f2b6fbe34e87b3fd5b4b1fb0081c11e2ff1ba42777c50d243eea306ec9211bf820211708f2fc395a WHIRLPOOL db63a490006d5fc53642448a3b19154bc48597a57b052413c42c7713a56665edae1505f9a2f432f88bb37ae5d7563743fc3a25b929896ca3e55a2365e2cd19c4
+DIST eselect-python-20160222.tar.bz2 48584 SHA256 be266ed02c60d4c44d07b575af87e4f9d3f952e387d8edb98edabbb72e855b75 SHA512 d0e424887594a1ffc0ce4f141e5c7d73763a49a2ec209b55ac2978a0bf82db9eaa3f07cc1c6650f609e6003f8292a260ce802c89f973b94c8a9a7c1d1ca84e3c WHIRLPOOL ba52a724fd3478b891d0c6a495885601bcc7f3bda713a5fd2e1c07ca1230d8a542ceb627329675f9935c07735e4de4a43d3d64d44771434cc4bbe9fb1cec6003
diff --git a/app-eselect/eselect-python/eselect-python-20160222.ebuild b/app-eselect/eselect-python/eselect-python-20160222.ebuild
new file mode 100644
index 000000000000..dbfcd6cf0118
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20160222.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# python-exec-2.4.2 for working -l option
+RDEPEND=">=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2"
+
+src_prepare() {
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}