summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-23 11:40:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-23 11:40:30 -0400
commitc664310e64126196cc86056790636f1206accf1e (patch)
tree394da25471f820c12783fe0eb9c85205a08ff542 /app-eselect
parentnet-misc/dropbox: drop 177.4.5399, 178.4.4811, 180.4.4912 (diff)
downloadgentoo-c664310e64126196cc86056790636f1206accf1e.tar.gz
gentoo-c664310e64126196cc86056790636f1206accf1e.tar.bz2
gentoo-c664310e64126196cc86056790636f1206accf1e.zip
app-eselect/eselect-wine: drop 2.0.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-wine/eselect-wine-2.0.2.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/app-eselect/eselect-wine/eselect-wine-2.0.2.ebuild b/app-eselect/eselect-wine/eselect-wine-2.0.2.ebuild
deleted file mode 100644
index dc64574f7852..000000000000
--- a/app-eselect/eselect-wine/eselect-wine-2.0.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Manage active Wine slots and variants"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Wine"
-SRC_URI="https://gitweb.gentoo.org/proj/eselect-wine.git/snapshot/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+xdg"
-
-# xdg-utils needed for bug #884077
-RDEPEND="
- app-admin/eselect
- xdg? ( x11-misc/xdg-utils )"
-
-src_install() {
- insinto /usr/share/eselect/modules
- doins wine.eselect
-
- keepdir /etc/eselect/wine
-
- newenvd - 95${PN} <<-EOF
- PATH="${EPREFIX}/etc/eselect/wine/bin"
- MANPATH="${EPREFIX}/etc/eselect/wine/share/man"$(usev xdg "
- XDG_DATA_DIRS=\"${EPREFIX}/etc/eselect/wine/share\"")
- EOF
-
- # links for building, e.g. wineasio (bug #657748)
- dosym -r /etc/eselect/wine/wine /usr/lib/wine
- dosym -r /etc/eselect/wine/include /usr/include/wine
-
- # not required, but useful for e.g. binfmt that's not looking in PATH
- # (not doing this for everything as it gets troublesome to track)
- dosym -r /etc/eselect/wine/bin/wine /usr/bin/wine
-
- einstalldocs
-}
-
-pkg_preinst() {
- if has_version '<app-eselect/eselect-wine-2'; then
- # keep copy of still-set 'active' to auto-select same slots
- if [[ -e ${EROOT}/etc/eselect/wine/active &&
- ! -e ${EROOT}/etc/eselect/wine/eselect-wine-migration ]]; then
- cp "${EROOT}"/etc/eselect/wine/{active,eselect-wine-migration} || die
- fi
-
- # managed differently, need cleanup
- eselect wine unset --all || die
- rm -f "${EROOT}"/etc/eselect/wine/{active,installed,links/{any,vanilla,staging,proton,wine}} || die
- rmdir "${EROOT}"/etc/eselect/wine/links 2>/dev/null
-
- # some rare man dirs were created by old eselect, cleanup if now empty
- rmdir "${EROOT}"/usr/share/man/{de,fr,pl}.UTF-8{/man1,} 2>/dev/null
- fi
-
- # lacking QA_BROKEN_SYMLINK, and rather avoid live /usr changes wrt
- # bug #632576, nor create "owned" placeholders that will be clobbered
- [[ -e ${EROOT}/etc/eselect/wine/bin/wine ]] ||
- eqawarn "QA Note: broken symlinks QA is normal on first merge, targets created after"
-}
-
-pkg_postinst() {
- eselect wine update --if-unset || die
-
- rm -f "${EROOT}"/etc/eselect/wine/eselect-wine-migration || die # see preinst
-
- if [[ ! ${REPLACING_VERSIONS##* } ]] ||
- ver_test ${REPLACING_VERSIONS##* } -lt 2; then
- elog
- [[ ${REPLACING_VERSIONS} ]] &&
- elog "${PN} changed a bit, suggest reviewing 'eselect wine help' (and list)."
- elog "Please run '. ${EROOT}/etc/profile' to update PATH in current shells."
- fi
-}
-
-pkg_prerm() {
- [[ ${REPLACED_BY_VERSION} ]] || eselect wine update --reset # no die
-}