summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-23 22:15:30 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-23 22:15:48 +0100
commit11b4cdb9bfa35c180842c53187f9cdc93871172f (patch)
tree178545e343e8e6c0ee6bba938850fa3a9c0ac48b /app-forensics/honggfuzz/honggfuzz-1.0.ebuild
parentdev-lang/ghc: restore HCFLAGS=-O1 for UNREG arches (diff)
downloadgentoo-11b4cdb9bfa35c180842c53187f9cdc93871172f.tar.gz
gentoo-11b4cdb9bfa35c180842c53187f9cdc93871172f.tar.bz2
gentoo-11b4cdb9bfa35c180842c53187f9cdc93871172f.zip
app-forensics/honggfuzz: bump up to 1.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-forensics/honggfuzz/honggfuzz-1.0.ebuild')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-1.0.ebuild b/app-forensics/honggfuzz/honggfuzz-1.0.ebuild
new file mode 100644
index 000000000000..b87a2be35620
--- /dev/null
+++ b/app-forensics/honggfuzz/honggfuzz-1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer with feedback support"
+HOMEPAGE="http://google.github.io/honggfuzz/"
+SRC_URI="https://github.com/google/honggfuzz/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ sys-libs/libunwind
+"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-no-error.patch
+)
+
+DOCS=(
+ CHANGELOG
+ COPYING
+ CONTRIBUTING
+ README.md
+)
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
+}
+
+src_install() {
+ dobin ${PN}
+
+ einstalldocs
+}