summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-09 19:01:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-09 19:02:15 +0000
commit07201fba03ac285e39726ee2171222f09c629a64 (patch)
tree2cae7c322be8d834a90a77735115026dbfbf55a8 /app-forensics/honggfuzz/honggfuzz-1.3.ebuild
parentapp-text/aspell: stable 0.60.7_rc1 for hppa, bug #639646 (diff)
downloadgentoo-07201fba03ac285e39726ee2171222f09c629a64.tar.gz
gentoo-07201fba03ac285e39726ee2171222f09c629a64.tar.bz2
gentoo-07201fba03ac285e39726ee2171222f09c629a64.zip
app-forensics/honggfuzz: bump up to 1.3
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-forensics/honggfuzz/honggfuzz-1.3.ebuild')
-rw-r--r--app-forensics/honggfuzz/honggfuzz-1.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-forensics/honggfuzz/honggfuzz-1.3.ebuild b/app-forensics/honggfuzz/honggfuzz-1.3.ebuild
new file mode 100644
index 000000000000..eb072b67c9bf
--- /dev/null
+++ b/app-forensics/honggfuzz/honggfuzz-1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer with feedback support"
+HOMEPAGE="http://google.github.io/honggfuzz/"
+SRC_URI="https://github.com/google/honggfuzz/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ sys-libs/libunwind
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CHANGELOG
+ COPYING
+ CONTRIBUTING
+ README.md
+)
+
+src_prepare() {
+ default
+ if has_version ">=sys-libs/binutils-libs-2.29"; then
+ eapply "${FILESDIR}"/${PN}-1.1-binutils-2.29.patch
+ fi
+}
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" emake
+}
+
+src_install() {
+ dobin ${PN}
+
+ einstalldocs
+}