summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-11-27 18:40:49 -0500
committerMike Pagano <mpagano@gentoo.org>2018-11-27 18:41:03 -0500
commit87c757b2fc4f746b3059fc55cea023bfdb9c3c4d (patch)
tree13c0c166f3de79d08b52e2314237455d12218cdf /app-forensics/lynis/lynis-2.7.0.ebuild
parentdev-libs/libinput: Update python_check_deps() (diff)
downloadgentoo-87c757b2fc4f746b3059fc55cea023bfdb9c3c4d.tar.gz
gentoo-87c757b2fc4f746b3059fc55cea023bfdb9c3c4d.tar.bz2
gentoo-87c757b2fc4f746b3059fc55cea023bfdb9c3c4d.zip
app-forensics/lynis: Version bump
Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-forensics/lynis/lynis-2.7.0.ebuild')
-rw-r--r--app-forensics/lynis/lynis-2.7.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-forensics/lynis/lynis-2.7.0.ebuild b/app-forensics/lynis/lynis-2.7.0.ebuild
new file mode 100644
index 000000000000..df4bdf19881b
--- /dev/null
+++ b/app-forensics/lynis/lynis-2.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}