summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-03-14 08:53:25 -0400
committerMike Pagano <mpagano@gentoo.org>2021-03-14 08:53:25 -0400
commit48c9ca02f6e8c3c6c1e5561574fad553db4cee9f (patch)
treed17f5c06ed6c0c00653794f233626affd47a6d15 /app-forensics/lynis
parentdev-python/plumbum: bump to 1.7.0 (diff)
downloadgentoo-48c9ca02f6e8c3c6c1e5561574fad553db4cee9f.tar.gz
gentoo-48c9ca02f6e8c3c6c1e5561574fad553db4cee9f.tar.bz2
gentoo-48c9ca02f6e8c3c6c1e5561574fad553db4cee9f.zip
app-forensics/lynis: Install systemd service and timer file.
Thanks to Alessandro Barbieri for reporting. Closes: https://bugs.gentoo.org/775776 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-forensics/lynis')
-rw-r--r--app-forensics/lynis/lynis-3.0.3-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-forensics/lynis/lynis-3.0.3-r1.ebuild b/app-forensics/lynis/lynis-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..98be2c958313
--- /dev/null
+++ b/app-forensics/lynis/lynis-3.0.3-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils bash-completion-r1 systemd
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="https://cisofy.com/lynis/"
+SRC_URI="https://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ doman lynis.8
+ dodoc FAQ README
+ newdoc CHANGELOG.md CHANGELOG
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+ systemd_dounit "${S}/extras/systemd/${PN}.service"
+ systemd_dounit "${S}/extras/systemd/${PN}.timer"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}/etc/cron.daily/lynis."
+ einfo
+}