summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-03-04 18:01:07 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:02 +0100
commit38392dd6f35fadd3af7efa4cc9e27a35300c1d0a (patch)
tree51b744859845e99a6913e8f74d9a04da3a753899 /app-forensics/memdump/memdump-1.01-r1.ebuild
parentnet-im/spectrum2: bump to version 2.0.10.1. (diff)
downloadgentoo-38392dd6f35fadd3af7efa4cc9e27a35300c1d0a.tar.gz
gentoo-38392dd6f35fadd3af7efa4cc9e27a35300c1d0a.tar.bz2
gentoo-38392dd6f35fadd3af7efa4cc9e27a35300c1d0a.zip
app-forensics/memdump: EAPI 7 bump.
Closes: https://bugs.gentoo.org/679422 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11254 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-forensics/memdump/memdump-1.01-r1.ebuild')
-rw-r--r--app-forensics/memdump/memdump-1.01-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-forensics/memdump/memdump-1.01-r1.ebuild b/app-forensics/memdump/memdump-1.01-r1.ebuild
new file mode 100644
index 000000000000..6564ca1be225
--- /dev/null
+++ b/app-forensics/memdump/memdump-1.01-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple memory dumper for UNIX-Like systems"
+HOMEPAGE="http://www.porcupine.org/forensics"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-linux3.patch )
+
+src_prepare() {
+ default
+ sed -i -e 's:$(CFLAGS):\0 $(LDFLAGS):' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" XFLAGS="${CFLAGS}" OPT= DEBUG=
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]];
+ then
+ einfo "Cannot test with FEATURES=userpriv"
+ elif [ -x /bin/wc ];
+ then
+ einfo "testing"
+ if [ "`./memdump -s 344 | wc -c`" = "344" ];
+ then
+ einfo "passed test"
+ else
+ die "failed test"
+ fi
+ fi
+}
+
+src_install() {
+ dosbin memdump
+ dodoc README
+ doman memdump.1
+}