summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-06-01 08:49:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-06-01 08:49:46 +0100
commite5106ec904f219a27123b3ea54a40ce0fab249b6 (patch)
treee0a83072a4127cdc2b0f298101f8d716676618c0 /app-forensics/zzuf
parentnet-libs/libbloom: respect user's AR (diff)
downloadgentoo-e5106ec904f219a27123b3ea54a40ce0fab249b6.tar.gz
gentoo-e5106ec904f219a27123b3ea54a40ce0fab249b6.tar.bz2
gentoo-e5106ec904f219a27123b3ea54a40ce0fab249b6.zip
app-forensics/zzuf: make static-libs optional
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/726578 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-forensics/zzuf')
-rw-r--r--app-forensics/zzuf/zzuf-0.15-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-forensics/zzuf/zzuf-0.15-r1.ebuild b/app-forensics/zzuf/zzuf-0.15-r1.ebuild
new file mode 100644
index 000000000000..1675ba16366a
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://caca.zoy.org/wiki/zzuf"
+SRC_URI="https://github.com/samhocevar/zzuf/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="static-libs"
+
+# Uses dlopen hack to hijack many libc functions.
+# Fails 2 tests with sandbox enabled: check-zzuf-A-autoinc check-utils
+RESTRICT="test"
+
+DOCS=( AUTHORS COPYING TODO )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}